Prop Compiling troubles

Discussion in 'Mapping Questions & Discussion' started by SuspiciousToad, Feb 21, 2015.

  1. SuspiciousToad

    SuspiciousToad L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    Hello. I have been having some trouble compilling my prop to Team Fortress 2 so that I can use it with hammer editor. So basically, I got all my files ready (My .qr files, my .smd files, etc...) and decided to finally compile with GUIstudioMDL 2.2. So basically, I setted up the programs, pressed the Compile button and got this error:

    Created command line: "C:\Program Files (x86)\Steam\SteamApps\common\SourceSDK\bin\orangebox\bin\studiomdl.exe" -game "C:\Program Files (x86)\Steam\steamapps\common\team fortress 2\tf" -nop4 -nox360 "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf\materials\models\props\Door\door.qc"

    Can't find steam app user info.

    Judging on how it says "Steam app user info" at the end, I'm guessing it still thinks that the folders are still set up like how it was before the steam pipe update (when it was Steam\Steamapps\username. I could be wrong though).
    Is there any way I can fix this? Or even better, is there another more up to date program that I can use to compile my model?:confused::confused::confused:
     
  2. Egan

    aa Egan

    Messages:
    1,313
    Positive Ratings:
    1,491
    This is the program I've been using which works in SteamPipe.
    I think, as you do, that guistudiomdl 2.2 is just old and looking in the wrong location, but I don't use it so I don't know how to fix it. ¯\_(ツ)_/¯
     
    • Thanks Thanks x 1
  3. SuspiciousToad

    SuspiciousToad L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    Thanks man. But I found another problem. When I compile my model and then view it in my
    model viewer, all I see is the generic black and purple checkers. I made sure that my VMT is set to vertexlitgeneric and that it was named properly. Is there some way to fix this?
     
  4. SuspiciousToad

    SuspiciousToad L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    Wait, nevermind. I just had to edit the .qc file a little bit to fix it.