problem with func_detail

Discussion in 'Mapping Questions & Discussion' started by JTG, Jan 16, 2008.

  1. JTG

    JTG L2: Junior Member

    Messages:
    61
    Positive Ratings:
    1
    So, I'm working on my map this morning. I tweak some lights and such, compile and load the map in TF2... and it's awful. Everything in way, way too dark. So, I go back into Hammer... every thing that I func_detailed... is no longer func_detailed. I was irritiated, to say the least. So, I try to func_detail something as a test and and it won't stay tied to the entity. As soon as I click away and then back, it's no longer func_detailed.

    Anyone have a clue what's going on here?
     
  2. TheFragMan

    TheFragMan L1: Registered

    Messages:
    33
    Positive Ratings:
    1
    Try switching between "groups" and "objects" by the buttons in the top right. I can't recall exactly how it works because I'm not in Hammer, but sometimes it doesn't recognize something as what it really is if you are in a different selection mode.

    Does that make any sense? Try it and see if it helps.
     
  3. Hawk

    Hawk L7: Fancy Member

    Messages:
    419
    Positive Ratings:
    212
    Does your compile log say anything about having leaks? If your map has a leak, Vrad doesn't compute bounce light, and everything looks darker (especially ceilings). One cause for your leaks (if you have them) may actually be the func_details you've made. A func_detail can't plug a leak.
     
  4. JTG

    JTG L2: Junior Member

    Messages:
    61
    Positive Ratings:
    1
    Hmm, I'll try that FragMan and get back to you.

    Hawk, I'm about 99% sure I show no leaks, but just in case I'll go back and check the log (I always save the latest one :)) and see if I just missed it somehow.
     
  5. JTG

    JTG L2: Junior Member

    Messages:
    61
    Positive Ratings:
    1
    I think that was it, FragMan. Thanks for the help.
     
  6. greenridge

    greenridge Guest

    Positive Ratings:
    0
    if you have the "ig" ignore groups button pushed, when you select a brush it will ignore tied entities. also if you use model's textures on walls some weird lighting effects may occur