Ooh boy, new computer, Vista and Hammer problems?

Discussion in 'Mapping Questions & Discussion' started by Ninjilla, Mar 4, 2009.

  1. Ninjilla

    Ninjilla L7: Fancy Member

    Messages:
    445
    Positive Ratings:
    55
    So Im compiling and error checking my map, getting rid of the leaks, but when I finally get it leak free and try to compile, the process gets stuck on vvis32.exe. hammer stops working, trying to draw the portals IIRC, it keeps building from 1 to around 10 VERY slowly, and Hammer says NOT RESPONDING. Is this Vistas fault? Also, after closing hammer, the vvis still goes on, and makes my processor use 100% of it (which is rather alot for a quad core 2.5). Any help fellow mappers? I'll try to grab a screenie when Hammer isnt being a complete tard >_<
     
  2. Vigilante212

    Vigilante212 L7: Fancy Member

    Messages:
    481
    Positive Ratings:
    33
    As far as I know hammer isnt even dual core optimized.
    May I ask what your setup is?
    Depending on map size and lighting vvis can take along time to run. If vvis is taking a long long time, try optimizing your map adding nodraw to non visible surfaces, turning geometry that doesnt need to block visavility into func_detail etc etc.
     
  3. Ninjilla

    Ninjilla L7: Fancy Member

    Messages:
    445
    Positive Ratings:
    55
    Setup meaning my PC or Hammer? I guess it could be vvis just taking forever, but my map isnt too big nor did it take too long to compile before. Maybe now that there are no leaks it actually has to calculate lighting? Its 2 AM here, so I shall try and wait for the full compile tomorrow. Thanks :]
     
  4. Spike

    Spike L10: Glamorous Member

    Messages:
    716
    Positive Ratings:
    82
    Source compiler is dual core optimized, and quad core optimized, means it will take 100% of processor.

    I'm 100% sure it's a problem of bad optimization. If things done correctly, VIS shouldn't take more than 30 seconds, no matter how big is your map (without HINTS).

    Even my Q6600 4x2.4 GHz @ 3.0 GHz crashes on VIS if I don't func_detail things.
     
  5. Vigilante212

    Vigilante212 L7: Fancy Member

    Messages:
    481
    Positive Ratings:
    33
    Yea ninj vvis wont even run if you have leaks. and i was referring to your computer setup.
     
    • Thanks Thanks x 1
  6. Ninjilla

    Ninjilla L7: Fancy Member

    Messages:
    445
    Positive Ratings:
    55
    Ah, I was thinking about optimizing my map today, thanks for the hints with vvis. Never knew it didnt run if there was one leak. Ive never optimized before (this is the furthest Ive gotten on a map, hope it gets to alpha:p), so this shall be a fun experience. To Hammer and the eventual ctrl+T spam!

    my PC is a quadcore 2.5 ghz, 4gb of Kingston X RAM, 2 9600 GTX+ GPUs in SLI.