1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

Odd SFM Lighting Bugs In Map

Discussion in 'Mapping Questions & Discussion' started by Exactol, Aug 21, 2015.

  1. Exactol

    aa Exactol Certified Hammer Hacker

    Messages:
    401
    Positive Ratings:
    472
    Not sure if its the map or SFM, but weird lighting errors are occuring on my map in SFM.

    [​IMG]

    [​IMG]

    Map if anyone wants to look at it: https://www.dropbox.com/s/zwghahv41zwhdan/bank1.bsp?dl=0

    My main suspect is that I created a large func_viscluster covering the scene so i didnt have to compile complex vis for SFM
     
    Last edited: Aug 21, 2015
  2. HolySnickerPuffs

    aa HolySnickerPuffs Bad at TF2, Loves Mapping For TF2

    Messages:
    949
    Positive Ratings:
    1,297
    This could be because odd brushwork. Does the map have many 'func_'s in it?

    EDIT: This thread might have what you're looking for.
     
  3. Exactol

    aa Exactol Certified Hammer Hacker

    Messages:
    401
    Positive Ratings:
    472
    theres almost no func_ stuff and the map shows up fine in tf2
     
  4. Exactol

    aa Exactol Certified Hammer Hacker

    Messages:
    401
    Positive Ratings:
    472
  5. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,035
    Positive Ratings:
    4,499
    It's probably because of your viscluster. VRAD needs vvis info to compile correctly, so if it VVIS tells it something really weird I can see this occurring. You're going to have to optimize your map. That'll probably make it run better in SFM though.
     
  6. Exactol

    aa Exactol Certified Hammer Hacker

    Messages:
    401
    Positive Ratings:
    472
    An update: having vis does not fix the problem
     
  7. Exactol

    aa Exactol Certified Hammer Hacker

    Messages:
    401
    Positive Ratings:
    472
    Problem solved. for some reason func detailing the roof or something fixed it. gg volvo