Odd problem with Source SDK

Discussion in 'Mapping Questions & Discussion' started by Ost, Jan 9, 2010.

  1. Ost

    Ost L2: Junior Member

    Messages:
    61
    Positive Ratings:
    32
    EDIT: Working now. I went into "Edit Game Configuration" and added a new game, which I named "Team Fortress 2", with the same directory as Team Fortress 2. It gave me an error message and suddenly it was working.

    So, a couple of days ago, I got this very annoying, and strange, problem with the SDK. When I'm supposed to change what game I'm launching Hammer with, I can't select TF2.
    The "Engine Version" is set to Orange Box. When I click the drop-down box to select Team Fortress 2, nothing happens - it just stays at Episode 2.

    Reinstalling SDK and TF2 did not help. I'd prefer not to reinstall Steam because I've got a lot of games installed with it, and re-downloading them would be a major pain.

    No idea why it's this way - as far as I know I've not changed any settings or anything on my computer recently.

    It works fine on my other computer, and it the SDK works flawlessly with all the other games I have installed - just not with TF2.

    Halp pl0x?

    (And yes, I did try searching. Nothing similar to my problem came up.)
     
    Last edited: Jan 9, 2010
  2. Steff0o

    Steff0o L6: Sharp Member

    Messages:
    295
    Positive Ratings:
    115
    have you tried "reset game configurations" ?
     
  3. Ost

    Ost L2: Junior Member

    Messages:
    61
    Positive Ratings:
    32

    Just tried it, didn't solve it.
     
  4. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Have you run TF2 at least once?
     
  5. Ost

    Ost L2: Junior Member

    Messages:
    61
    Positive Ratings:
    32
    After resetting? No, I'll try.

    Tried. Still nothing.

    EDIT: I managed to fix it myself. This thread now can be locked or deleted.
     
    Last edited: Jan 9, 2010