1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

Needing help! Weird Hammer error!

Discussion in 'Mapping Questions & Discussion' started by Janeator, Dec 17, 2012.

  1. Janeator

    Janeator L2: Junior Member

    Messages:
    66
    Positive Ratings:
    26
    Hello everyone! First of all, i have no idea if this is on its correct place in the forums. Then: I used the search bar to search for this problem, but couldn't find any fix. Also did on Google, found some but none worked.


    The problem:

    1. I start Source SDK, Select Source Engine MP and Team Fortress 2, then i open Hammer.

    2. On the 'messages' window a weird red message saying 'Failed to initialize texture system' appears.

    3. I try opening a map, and a pop-up with the tittle 'FATAL ERROR' appears. Its message: 'Missing material 'editor/wireframe'. Go to Tools | Options | Game Configurations and verify that your game directory is correct.' It is.

    4. Same message appears a few times after clicking accept, until a different one appears: 'No textures are available for use with that game. You must set them up in the Textures tab of the Options dialog box before you can edit maps for this game.' And the 'Configure Hammer' window appears (same tan going to tools|options).

    5. Accept or cancel, Hammer crashes.

    Now i THINK this may be happening because of a server i joined yeserday. Note before yesterday hammer was working fine (fine in italics because it got frozen while compiling too many times, i think due to the spawn door i was trying to create).
    That server was an 'item test' server. like, adquiring shitty workshop items to 'test' just for that server. with a plugin or something, idk.
    Aaaaaand yes, i tried Refreshing the SDK content, the game configurations.....

    So what's wrong? i actually deleted everything inside the Sourcesdk folder to make it regen it and see if that worked, but apparently the copy of those files it got somewhere was made after i left that server.... wich is wreid, as i didn't use hammer till now. And, well, i guess it's about this, or else i have no idea what is it about. Note i started using hammer 2 weeks ago, so i don't have much idea about it.

    I think one thing that may fix it is restoring my sourcesdk files to the original ones, but as reinstalling source SDK didn't do that (rather copy those saved somewhere ones) i'd need someone to send them to me.

    Anyway, thanks in advance for the help, if any is given.

    EDIT: Thanks Site staff for moving it to the right section, but please i still need help!
     
    Last edited: Dec 17, 2012
  2. ROFLsnakes

    ROFLsnakes L2: Junior Member

    Messages:
    72
    Positive Ratings:
    5
    1) Try going to Source under you "tools" in steam.
    2) Right click Source and choose "properties"
    3) Look for the tab "local files"
    4) Select "verify integrity of tool cache".

    Since you deleted some of the source files I'd check this first-it will take about 15 mins. I'd also do this with Team Fortress.

    Now open the SDK. on the main screen where you click on Hammer Editor select the "refresh SDK content" button, and the "reset configurations".

    Hope this helps.
     
  3. Janeator

    Janeator L2: Junior Member

    Messages:
    66
    Positive Ratings:
    26
    to "verify the integrity of tool cache" should open a window that says 'validating files', no? That uses to appear almost every day i want to play tf2. And i forgot to mention i already did so with hammer too, but meh, gonna try again. After all today is a new day, maybe it's randomly fixed, as it 'randomly' broke. I hope so, but i don't think so.



    [5 mins later:] Hammer cache 100% validated. It's all right. I'm doing it with tf2 too as you said, but i expect it to be alright too.

    EDIT: TF2's Cache was right too.
    On another page i found something similar to your fix suggestion (wich doesn't work :'( ) that is starting the game at least 1 time between verifying the cache and refreshing the source stuff.

    And then another problem appeared. I cannot run TF2 Either. WHY ;A;
    Please help
     
    Last edited: Dec 18, 2012
  4. Janeator

    Janeator L2: Junior Member

    Messages:
    66
    Positive Ratings:
    26
    (Yeah IK it's doublepost)

    Hi! First of all i wanna say this fix i found (yeah finally) might not work for everyone looking for a fix to this problem, but similary no other fix worked for me. Actually, i found that fix while trying to find any other valve game or any other gamemaker game i had. Also Cobalt did crash. (It is, btw, strange that Minecraft worked fine).

    So i decided to go and try updating my Video Card / graphics card /whatever >-<

    And worked.

    The fact is i don't know why the hell did these things crash because of he card, as no message told me to update it, not even the games did so. NOTHING did so. And that's what makes me angry. Windows, do i have to manually check for updates everytime i see everything is going to.... ?
    (Althrough i may be getting angry for nothing; is it possible to make windows update those things automatically? Sorry if you considerate this a noob question....)


    So um i guess any op can close the thread now, unless someone doesn't want them to do so. I'd say fixed.
     
  5. Donk

    Donk L1: Registered

    Messages:
    20
    Positive Ratings:
    4
    Well fantastic, Now i'm having this problem and I don't have the spare cash for a new graphics or video card. I tried the validation and it wont do anything.
     
  6. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,884
    Positive Ratings:
    5,127
    Try updated the drivers. I think that's what that post was referring to.
     
  7. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,441
    Positive Ratings:
    1,196
    Source SDK's hammer is proven to be broken and not work anyway? Why try to revive it?
     
    • Agree Agree x 2
  8. Donk

    Donk L1: Registered

    Messages:
    20
    Positive Ratings:
    4
    I've tried hammer from SDK and from the regular files. I've reinstalled the games I got it from, nothing works.
     
  9. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,441
    Positive Ratings:
    1,196
    Have you done what you need to get /bin Hammer working? As in: have successfully loaded up tf2 at least once, run hammer.bat, then use hammer.exe?
     
  10. Donk

    Donk L1: Registered

    Messages:
    20
    Positive Ratings:
    4
    Nevermind I broke everything and now i have to reinstall everything
     
    Last edited: Apr 6, 2017