My steam is being weird?

Discussion in 'Team Fortress 2 Talk' started by AntonJ3000, Feb 13, 2009.

  1. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    Not sure if this fits in the Team Fortress 2 Talk category.

    But anyway:
    When I start my computer, steam no longer launches itself. It just adds the steam.exe to task manager and then I close it and try to start steam, it starts some windows installer, so I close it down and start it from the steam folder (C:/Spel/Steam/steam.exe) then it logs in for like 30minutes.
    And also launching games take like 10 minutes, and sometimes they never start.

    Anyone know what is wrong?
     
  2. Queops

    Queops L2: Junior Member

    Messages:
    77
    Positive Ratings:
    3
    I don't want to be rude or anything but your best bet is looking at the Steam FAQ or just post at Steam Official forums, not posting here ;) Besides that, this is TF2 talk forums, so it doesn't quit fit
     
    Last edited: Feb 13, 2009
  3. drp

    aa drp

    Messages:
    2,251
    Positive Ratings:
    2,551
    try deleting your clientregistry.blob file
     
  4. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    Thanks, that fixed the slow login, but the windows installer problem is still there.
     
  5. drp

    aa drp

    Messages:
    2,251
    Positive Ratings:
    2,551
    Have you tried verifying your gcf files?

    open up your games tab and right click on tf2. go to properties and go to the 'local files' tab. click to verify integrity...
     
  6. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    Yeah, I've done that some times. But that's not really the problem, the problem is when I start steam normally, this comes up. "Preparing installation..."

    Then:

    Code:
    The feature you are trying to use is on a network resource that is unavailable.
    
    Click OK to try again or enter an alternate path to a folder containing the installation package 'SteamInstall.msi' in the box below.
    I click OK and this comes up
    Code:
    The path 'C:Documents and settingsAntonJSkrivbordSteamInstall.msi' cannot be found. Verify that you have acess to the location and try again, or try to find the installation package 'SteamInstall.msi' in a folder from which you can install the product steam
    But it isn't so much of a problem because now I added a link to C:/Spel/Steam/Steam.exe to my desktop. So it dosen't really matter.


    Oh, and also sometimes when it starts I get

    "Fatal Error: Failed to load platform modules"


    I've tried:
    1. Ensure that Steam is not running (close any error dialog windows).
    2. Go to the Start button and select Run....
    3. Enter regedit and press OK.
    4. Navigate to the HKEY_CURRENT_USER\Software\Valve\Steam registry folder.
    5. Locate and double-click the Language registry key.
    6. Enter english in the Value data field and click OK.
    7. Start Steam.

    But was already english in the field, gonna try to copy lots of my folders and reinstall now.
     
    Last edited: Feb 15, 2009