My map won't run ;_;

Discussion in 'Mapping Questions & Discussion' started by The Asylum, Apr 13, 2008.

  1. The Asylum

    aa The Asylum

    Messages:
    1,658
    Positive Ratings:
    439
    So it's like this:

    I'm building on the beta version of my map, and when I go to compile what I've got thus far, after TF2 loads, it aborts loading the .bsp

    Any ideas what could be causing this?
     
  2. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,745
  3. Nosher

    Nosher L4: Comfortable Member

    Messages:
    184
    Positive Ratings:
    20
    Is there a SPACE in the map name?

    eg:-

    Beta 1 Forest = WRONG
    Beta_1_Forest = CORRECT

    Good luck
    Nosh
     
  4. The Asylum

    aa The Asylum

    Messages:
    1,658
    Positive Ratings:
    439
    So I did what that site said and rebooted Hammer

    "2 solids couldnt be loaded due to errors in the file"

    Curious, I then scoured the map for said missing solids.

    .... nothing. Nothing was missng at all.

    Wierd. Anyway, thanks
     
  5. Ze Inspector

    Ze Inspector L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    If you have an errors in a solid that cause your compile to fail, that is most likely due to the shapes being illegal or concave. If you RELOAD a map that has solids like that hammer will sometimes "fix" them by changing the vertexes until the shape is legal again. Check any complex geometry you may have made and see if any of your shapes have been changed.