MVM: Tank crashes server on custom map

Discussion in 'Mapping Questions & Discussion' started by George The Spud, Nov 12, 2013.

  1. George The Spud

    George The Spud L1: Registered

    Messages:
    6
    Positive Ratings:
    0
    I am currently looking to create Mann Versus Machine maps for Team Fortress 2. I have already began construction of my first simple map, conforming to the example map provided with Team Fortress 2.
    So far it works almost perfectly. The robots will spawn in and make their way to the hatch without issues.
    The main problems start on tank waves. When it is time for a tank to spawn, the server immediately crashes. I have placed a path within the map for the tank to follow, leading from its spawn to the hatch, and the beginning node for the path has the same name as the one specified in the population file. Yet, the tank spawning seems to crash the game.
    Any advice to solving this problem would be greatly appreciated.
     
  2. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,841
    Positive Ratings:
    4,765
    Make sure of these things:

    * The path track is continuous, doesn't have loops or breaks and ends at the hatch
    * There is a navmesh generated everywhere the tank rolls. The tank uses the navmesh for it's angle/collision calculation, and only uses the path_tracks as a guide on what way to go. Having no nav mesh (especially at the first path_track) messes with it.
    * Make sure the tank is correctly set up in the popfile
    * Triple check the name of the path_track is correct
     
  3. George The Spud

    George The Spud L1: Registered

    Messages:
    6
    Positive Ratings:
    0
    Ah, thank you very much. I had placed a player_clip barrier in front of the tank's spawn room, thus the nav_generate command did not register it as a walkable space. I appreciate your help.
     
  4. George The Spud

    George The Spud L1: Registered

    Messages:
    6
    Positive Ratings:
    0
    Hmmm... Scratch that actually. Even with a nav mesh expanding across all areas that the tank must access, I'm afraid I'm still getting the same problem. The moment the tank is supposed to spawn, the server crashes.