Lighting issues

Discussion in 'Mapping Questions & Discussion' started by noodleboy347, Oct 4, 2012.

  1. noodleboy347

    noodleboy347 L1: Registered

    Messages:
    30
    Positive Ratings:
    0
    Hello, my map appears to be having some serious lighting/shadowing issues. For one, some props appear unusually darker than they should be. Some areas are drastically darker than they should be. Here is a small gallery of screenshots:

    http://imgur.com/a/GSLuZ

    Anyone know what the cause of this problem could be? I know that it is not a map leak as it compiles fine.
     
  2. Pocket

    aa Pocket func_croc

    Messages:
    4,480
    Positive Ratings:
    2,212
    The "dark areas" (barring the one under the steps) look about right for unlit areas to me. The dark props are probably due to being jammed into a block that isn't hollow, which means the lighting origin is inside the brush. That'll clear up when you start compiling with advanced lighting options, but for now you can remedy it by placing an info_lighting entity somewhere in front of the brush and attaching the props to it.
     
    • Thanks Thanks x 1
  3. noodleboy347

    noodleboy347 L1: Registered

    Messages:
    30
    Positive Ratings:
    0
    Well, the info_lighting works great, but I've tried compiling with a bunch of different options but the props all look bad if they don't have an info_lighting to accompany them. What advanced lighting options are you referring to?

    EDIT: I figured it out myself, thank you for the help!
     
    Last edited: Oct 4, 2012