Help with screen overlays

Discussion in 'Mapping Questions & Discussion' started by JCapps, Feb 18, 2014.

  1. JCapps

    JCapps L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    I have an env_screenoverlay that triggers fine, but the texture custom texture that I am using for it flickers a lot. Here is the vmt:

    "UnlitGeneric"
    {
    "$basetexture" "PvZ\pvz_huge_wave"
    "$ignorez" 1
    "$translucent" 1
    }

    Here is the image. A simple 1024x1024 texture. It fits fine and pops up fine. It's just the flickering that is annoying. How can it be fixed?
     
  2. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,818
    Positive Ratings:
    4,660
    try using $alphatest 1 rather than translucent 1
     
    • Thanks Thanks x 1
  3. Egan

    aa Egan

    Messages:
    1,302
    Positive Ratings:
    1,478
    I just used a slightly modified version of the built-in screen overlays and it worked fine:

    "UnlitGeneric"
    {
    "$baseTexture" "egan/justin_hud"
    "$translucent" "1"
    "%keywords" "tf"
    "$scale" "[1 1]"
    }
     
  4. JCapps

    JCapps L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    That worked. Danke comrade! :)
     
  5. Pocket

    aa Pocket func_croc

    Messages:
    4,480
    Positive Ratings:
    2,213
    Actually, since what you have is just plain-colored text an outline, with I would recommend trying to make a $distancealpha-compatible texture, like the hovering no-entry symbols they use for respawn rooms, out of your base text and generating the outlines with the VMT.