[Help] Error "BasePolyforPlane : no axis found" when opening my map

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

Sonitrok

L1: Registered
Jun 3, 2015
23
Does someone knows what is this error and how to fix it ? I have heard somewhere that i had to open the vmf file and find the "nan" to replace the numbers by a working value like 3000. I tried to do so but it didn't solved it. I honestly don't get it. Can someone help me fixing it ?
 

Sonitrok

L1: Registered
Jun 3, 2015
23
Okay, thank for your help ! It helped me to look in the right direction !

I dove into the vmf file and compared it with other vmf codes of maps i made that i knew they were working, and i found the bugged part and fixed it. Here's what i learned in details if someone have the same problem later :

In your vmf file, there is this part of the code :

"
}
side
{
"id" "46"
"plane" "(-12288 -15104 64) (-12288 -15168 64) (-12288 -15168 1536)"
"material" "TOOLS/TOOLSNODRAW"
"uaxis" "[0 1 0 0] 0.25"
"vaxis" "[0 0 -1 0] 0.25"
"rotation" "0"
"lightmapscale" "16"
"smoothing_groups" "0"
"

On the line "plane" there is big negative value, an other big negative value then a little positive number. When this error appears "BasePolyForPlane : no axis found" it means that the first and second values (the two big negative ones" are unknow by the software, so he replaced it by something like -nan(ind) instead of the actual number, so the bugged line should look like this :

"plane" "(-nan(ind) -nan(ind) 448) (-nan(ind) -nan(ind) 416) (-nan(ind) -nan(ind) 416)"

to fix it, use control+F and search for -nan(ind) to find them all, then replace them by a negative big number, such as -3000, -12000, -15000, -18000...

Once you found and replaced them all, save, close, launch the map with hammer and it should be working. The software will also inform you that some brushes bugged and have been deleted in the process (like 2 or 3). It's not really that much when compared to the fact that you actually get back the entire map.

Hoping this will help someone reading this in the future having the problem as i had !
 

XaCuXo

L1: Registered
Aug 17, 2017
1
I am having the same problem getting this error, though I searched through the .vmf though with not much luck on finding the error. This is extremly frustrating because I am almost done with the map and really don't feel like redoing everything, just for it to give me the same error.