Hammer won't let me save to a custom location.

Discussion in 'Mapping Questions & Discussion' started by lukasturbo, Jul 19, 2016.

  1. lukasturbo

    lukasturbo L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    I'm having a really strange problem with Hammer. Whenever I try to save a file it only allows it to save to C:\Users with a custom name, otherwise it will save as "C:\Users\Default.vmf". If I don't run it as an admin, I get this message: "You don't have permission to save in this location. Contact the administrator to obtain permission.", but I am the administrator. And if I try to overwrite the file I get this message: "Hammer was unable to backup the existing file "C:\Users\Default.vmf" (Error 0x5). Please verify that there is space on the hard drive and that the path still exists.", I have 280GB free.

    The last time I used Hammer (a few months back) everything was fine and not much has changed: same PC, same OS.

    Please help me.
     
  2. Gabe Noodle from Volvo

    Gabe Noodle from Volvo L3: Member

    Messages:
    142
    Positive Ratings:
    32
    It's a security setting, programs can't directly access the C drive unless you give them permission. Just set it to run as administrator in the properties.
     
  3. lukasturbo

    lukasturbo L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    I already set it to run as an admin in the properties. But I have found a bypass. I can save the file in Users folder and then just drag it wherever I want and Ctrl+S works fine. Only "Save as" doesn't work.