Hammer sappin my verts

Discussion in 'Mapping Questions & Discussion' started by Jayden, Aug 18, 2010.

  1. Jayden

    Jayden L1: Registered

    Messages:
    42
    Positive Ratings:
    1
    I'm becoming very adept at breaking hammer.

    I've been doing some vert editing to position brush's for displacement down the line. This consists mainly of vert-manipulated cubes and some cubes that I merged verts to create one less face. I'll have them aligned perfectly, save the VTF, close it, reopen it and ther vertices will be out of place. It's driving me nuts!

    Just before a save: Link

    Just after a save after closing and reopenign hammer: Link

    I sent my buddy the same VMF, he opened it, closed it, didn't seem to have a problem
     
  2. Karnage

    Karnage L3: Member

    Messages:
    114
    Positive Ratings:
    49
    before you save hit alt-p to check for errors. It might be that the geometry you're creating is "invalid" and should be split up more or done differently. You can click fix to see if Hammer actually fixes the problem without catapulting a vertex into infinity
     
  3. Mick-a-nator

    aa Mick-a-nator

    Messages:
    640
    Positive Ratings:
    314
    Definitely seems like an invalid face problem, though the fact that your friend doesn't have the problem is odd. Still worth checking that none of the faces are invalid, as Karnage explained.
     
  4. Jayden

    Jayden L1: Registered

    Messages:
    42
    Positive Ratings:
    1
    No idea why my buddy isn't havin the problem. Recreating and clippingthe erroneous faces seems to do the trick. I was making tunnels, waterbeds and caves...from now on, I think it's best to do it VERY blocky and do all the modeling with displacement
     
  5. Blue552

    Blue552 L3: Member

    Messages:
    137
    Positive Ratings:
    18
    Yea when you create a new edge on a face then concave it, it causes invalid face problems.