hammer not showing changes

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

wonkasnout2

L1: Registered
Jun 25, 2017
22
I have a few spots in my map, that I change in hammer, that dont show up in game. Does anyone know why this is happening/ what do I do? Here are pics:
Floor texture in Hammer:
floor-hammer.png
Floor Texture in game:
floor-ingame.jpg


Ramp in Hammer: (I wanted it to be a different texture, but changing it did nothing. I deleted it in hammer and it still shows up in game)
ramp-hammer.png
Ramp in game: (Wrong texture and its still there)
ramp-ingame.jpg
I also added some details to an upstairs area in spawn:
spawn-hammer.png
But ingame it looks like I never added it:
spawn-ingame.jpg


What do I do?!!?!
 

killohurtz

Distinction in Applied Carving
aa
Feb 22, 2014
1,020
This means there's an error in your map that's causing the compile to fail. If you've compiled it before, it just loads the old copy because it never got overwritten by the new one. The compile log will tell you exactly what the problem is - look at the last line of the first section (right before vvis.exe starts), or use the Interlopers log checker to find it. Or you can post it here (spoiler or pastebin please) if you're lost.
 

wonkasnout2

L1: Registered
Jun 25, 2017
22
I put it into interlopers, and I got 2 errors: Both of them say I have a displacment on a func_detail.

error: displacement found on a(n) func_detail entity - not supported (entity 261, brush 0)

error: displacement found on a(n) func_detail entity - not supported

can't load skybox file skybox/sky_well_01_hdr to build the default cubemap!


It turns out I must have accidentally put a displacement in a func_detail. I tied it to world and compiled again, but nothing changed. I put my new log into interlopers and got this:

can't load skybox file skybox/sky_well_01_hdr to build the default cubemap!

It seems I've solved the other two problems. Iv'e been getting this error for a while, but I never really worried about it (because my skybox is working). Do you think this is somehow affecting the compiling? or is it something else? I read through the log and didn't see anything.
 

killohurtz

Distinction in Applied Carving
aa
Feb 22, 2014
1,020
That particular skybox error is harmless and can be ignored. It just means the engine couldn't give you default cubemaps, but those are minor visual details that can be fixed manually.

Are you absolutely sure there are no other errors in the compile log?
 
Mar 23, 2013
1,015
Well post the compile log here? Interlooper doesnt catch everything.

EDIT: wait you did, but in a different thread. Why did you make two threads? That's pointless
 

wonkasnout2

L1: Registered
Jun 25, 2017
22
** Executing...
** Command: "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
** Parameters: -game "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\tf" "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix).vmf"

Valve Software - vbsp.exe (Jun 14 2017)
4 threads
materialPath: C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\tf\materials
Loading C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix).vmf
ConVarRef mat_reduceparticles doesn't point to an existing ConVar
Patching WVT material: maps/koth_buffonage(fix)/nature/blendgroundtogravel007_wvt_patch
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
Processing areas...done (0)
Building Faces...done (0)
Chop Details...done (0)
Find Visible Detail Sides...
Merged 194 detail faces...done (0)
Merging details...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (0)
writing C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix).prt...Building visibility clusters...
done (0)
*** Error: Skybox vtf files for skybox/sky_well_01_hdr weren't compiled with the same size texture and/or same flags!
Can't load skybox file skybox/sky_well_01_hdr to build the default cubemap!
*** Error: Skybox vtf files for skybox/sky_well_01_hdr weren't compiled with the same size texture and/or same flags!
Can't load skybox file skybox/sky_well_01_hdr to build the default cubemap!
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (0) (161838 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Compacting texture/material tables...
Reduced 672 texinfos to 490
Reduced 57 texdatas to 56 (1363 bytes to 1310)
Writing C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix).bsp
Wrote ZIP buffer, estimated size 1029, actual size 815
9 seconds elapsed

** Executing...
** Command: "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
** Parameters: -game "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\tf" "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix)"

Valve Software - vvis.exe (Jun 14 2017)
4 threads
reading c:\users\jack\desktop\steam stuff\steam, and all its shit\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix).bsp
reading c:\users\jack\desktop\steam stuff\steam, and all its shit\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix).prt
774 portalclusters
2473 numportals
BasePortalVis: 0...1...2...3...4...5...6...7...8...9...10 (1)
PortalFlow: 0...1...2...3...4...5...6...7...8...9...10 (313)
Optimized: 4839 visible clusters (1.82%)
Total clusters visible: 266091
Average clusters visible: 343
Building PAS...
Average clusters audible: 735
visdatasize:146176 compressed from 160992
writing c:\users\jack\desktop\steam stuff\steam, and all its shit\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix).bsp
5 minutes, 14 seconds elapsed

** Executing...
** Command: "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
** Parameters: -game "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\tf" "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix)"

Valve Software - vrad.exe SSE (Jun 14 2017)

Valve Radiosity Simulator
4 threads
[Reading texlights from 'lights.rad']
unknown light specifier type - lights

[56 texlights parsed from 'lights.rad']

Loading c:\users\jack\desktop\steam stuff\steam, and all its shit\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix).bsp
Setting up ray-trace acceleration structure... Done (4.08 seconds)
2727 faces
2 degenerate faces
237348 square feet [34178224.00 square inches]
18 Displacements
46087 Square Feet [6636568.00 Square Inches]
2725 patches before subdivision
30029 patches after subdivision
sun extent from map=0.026177
30 direct lights
BuildFacelights: 0...1...2...3...4...5...6...7...8...9...10 (17)
BuildVisLeafs: 0...1...2...3...4...5...6...7...8...9...10 (10)
transfers 2091500, max 588
transfer lists: 16.0 megs
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #1 added RGB(128962, 74798, 24725)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #2 added RGB(35579, 16028, 2872)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #3 added RGB(12170, 4580, 477)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #4 added RGB(4594, 1444, 93)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #5 added RGB(1852, 480, 20)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #6 added RGB(770, 163, 4)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #7 added RGB(327, 56, 1)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (1)
Bounce #8 added RGB(141, 19, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #9 added RGB(61, 7, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #10 added RGB(27, 2, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #11 added RGB(12, 1, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #12 added RGB(5, 0, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #13 added RGB(2, 0, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #14 added RGB(1, 0, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #15 added RGB(0, 0, 0)
Build Patch/Sample Hash Table(s).....Done<0.0192 sec>
FinalLightFace: 0...1...2...3...4...5...6...7...8...9...10 (7)
FinalLightFace Done
0 of 0 (0% of) surface lights went in leaf ambient cubes.
ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (7)
Writing leaf ambient...done
Ready to Finish

Object names Objects/Maxobjs Memory / Maxmem Fullness
------------ --------------- --------------- --------
models 12/1024 576/49152 ( 1.2%)
brushes 375/8192 4500/98304 ( 4.6%)
brushsides 2563/65536 20504/524288 ( 3.9%)
planes 2468/65536 49360/1310720 ( 3.8%)
vertexes 4899/65536 58788/786432 ( 7.5%)
nodes 1671/65536 53472/2097152 ( 2.5%)
texinfos 490/12288 35280/884736 ( 4.0%)
texdata 56/2048 1792/65536 ( 2.7%)
dispinfos 18/0 3168/0 ( 0.0%)
disp_verts 1458/0 29160/0 ( 0.0%)
disp_tris 2304/0 4608/0 ( 0.0%)
disp_lmsamples 113552/0 113552/0 ( 0.0%)
faces 2727/65536 152712/3670016 ( 4.2%)
hdr faces 0/65536 0/3670016 ( 0.0%)
origfaces 1429/65536 80024/3670016 ( 2.2%)
leaves 1684/65536 53888/2097152 ( 2.6%)
leaffaces 3488/65536 6976/131072 ( 5.3%)
leafbrushes 1734/65536 3468/131072 ( 2.6%)
areas 2/256 16/2048 ( 0.8%)
surfedges 19074/512000 76296/2048000 ( 3.7%)
edges 11015/256000 44060/1024000 ( 4.3%)
LDR worldlights 30/8192 2640/720896 ( 0.4%)
HDR worldlights 0/8192 0/720896 ( 0.0%)
leafwaterdata 0/32768 0/393216 ( 0.0%)
waterstrips 332/32768 3320/327680 ( 1.0%)
waterverts 0/65536 0/786432 ( 0.0%)
waterindices 5397/65536 10794/131072 ( 8.2%)
cubemapsamples 0/1024 0/16384 ( 0.0%)
overlays 10/512 3520/180224 ( 2.0%)
LDR lightdata [variable] 1348360/0 ( 0.0%)
HDR lightdata [variable] 0/0 ( 0.0%)
visdata [variable] 146176/16777216 ( 0.9%)
entdata [variable] 16670/393216 ( 4.2%)
LDR ambient table 1684/65536 6736/262144 ( 2.6%)
HDR ambient table 1684/65536 6736/262144 ( 2.6%)
LDR leaf ambient 8200/65536 229600/1835008 (12.5%)
HDR leaf ambient 1684/65536 47152/1835008 ( 2.6%)
occluders 0/0 0/0 ( 0.0%)
occluder polygons 0/0 0/0 ( 0.0%)
occluder vert ind 0/0 0/0 ( 0.0%)
detail props [variable] 1/12 ( 8.3%)
static props [variable] 1/23342 ( 0.0%)
pakfile [variable] 815/0 ( 0.0%)
physics [variable] 161838/4194304 ( 3.9%)
physics terrain [variable] 998/1048576 ( 0.1%)

Level flags = 0

Total triangle count: 7889
Writing c:\users\jack\desktop\steam stuff\steam, and all its shit\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix).bsp
46 seconds elapsed

** Executing...
** Command: Copy File
** Parameters: "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\KOTH_buffonage(fix).bsp" "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\tf\maps\KOTH_buffonage(fix).bsp"


** Executing...
** Command: "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\hl2.exe"
** Parameters: -game "C:\Users\Jack\Desktop\STeam stuff\Steam, and all its shit\Steam\steamapps\common\Team Fortress 2\tf" +map "KOTH_buffonage(fix)" -steam
 
Mar 23, 2013
1,015
You can use spoiler tags to avoid a long message like this:

Code:
[spoiler] compile log here [/spoiler]

Anyway I dont really see any major errors in your log.

Maybe it's the name of the map? First, do not capitalize any character in your map's name, it causes issues with Linux systems. And maybe dont use brackets either (calling a map "somethingsomething-fix is silly anyway imo. What if there is another bug to fix?)

The file paths are pretty funny. "\Desktop\STeam stuff\Steam, and all its shit\Steam\" :D Not an issue, just amusing

Also I spotted this: "2 degenerate faces". Sounds suspicious. Perhaps you have an invalid brush? You could try compiling parts of your map with the cordon tool :cordonedit::cordonenable: until you find the part that is uncompileable. Also press alt+P in hammer, it often tells you when you have an invalid brush.
 

wonkasnout2

L1: Registered
Jun 25, 2017
22
You can use spoiler tags to avoid a long message like this:

Code:
[spoiler] compile log here [/spoiler]

Anyway I dont really see any major errors in your log.

Maybe it's the name of the map? First, do not capitalize any character in your map's name, it causes issues with Linux systems. And maybe dont use brackets either (calling a map "somethingsomething-fix is silly anyway imo. What if there is another bug to fix?)

The file paths are pretty funny. "\Desktop\STeam stuff\Steam, and all its shit\Steam\" :D Not an issue, just amusing

Also I spotted this: "2 degenerate faces". Sounds suspicious. Perhaps you have an invalid brush? You could try compiling parts of your map with the cordon tool :cordonedit::cordonenable: until you find the part that is uncompileable. Also press alt+P in hammer, it often tells you when you have an invalid brush.
I pressed alt+p and it didn't show me anything useful. I used cordon on part of my map and some of the things that didn't show up worked, so the problem is not there. If/When I do find the area of the map the invalid brush is in, how do I know which one it is?
 
Mar 23, 2013
1,015
When using cordon tool, you could compile each half of the map once. In theory, one half shouldnt compile properly and now you will compile two halfes of that half again to further close in of the cause. Until you figured it out. As soon you are pretty close to what causes the error, remade any "weird" brush you have there. It's probably a brush you edited with a vertex tool or clipping tool.
Perhaps the brush is off-grid? Judging from your screenshots, it does look like you have several brushes which have vertexies which aren't on grid. This can be problematic, especially if they are world brushes.
 

wonkasnout2

L1: Registered
Jun 25, 2017
22
When using cordon tool, you could compile each half of the map once. In theory, one half shouldnt compile properly and now you will compile two halfes of that half again to further close in of the cause. Until you figured it out. As soon you are pretty close to what causes the error, remade any "weird" brush you have there. It's probably a brush you edited with a vertex tool or clipping tool.
Perhaps the brush is off-grid? Judging from your screenshots, it does look like you have several brushes which have vertexies which aren't on grid. This can be problematic, especially if they are world brushes.
Okay, so I used cordon to split my map in 2, I loaded both parts, and everything worked: meaning the bad brush was not there. I then loaded my entire map and everything worked fine. I have no idea why, or how, but it did... I guess the god of hammer is on my side. Thanks for your help, I have no clue what just happend, but Im not gonna question it.:)