F**KING HELL (problems with steam game/games need help)

Discussion in 'Off Topic' started by Numerous, Dec 8, 2009.

  1. Numerous

    Numerous L4: Comfortable Member

    Messages:
    150
    Positive Ratings:
    72
    So, I'm trying to join a server, and I join a server, and it starts to load and connect to the server and it stops and gives me a message that says "This steam account has been used to log in somewhere else. To continue using steam, you need to log in again."
    And underneath it is a button marked "login". So since that's the only thing i can click (apart from minimise/maximise/close at the very top right of the window) I click it, and it kicks me back to the menu screen, with the "choose server" screen still open.
    If I try to rejoin, the same thing happens. It never gets past "parsing game info", ever. If I keep rejoining and then clicking "login" after it gets to "parsing game info", at some point it just stops doing anything after getting to "parsing game info", and all i can do is click cancel (tried waiting).
    This has happened in TF2, in synergy, in HL2: DM, in CS, and they're only the cases where i can remember specific instances, it's probably happened in every multiplayer game I've played much. It's been happening for maybe a year or two or three now, and it started when I started using steam. Or soon after. I am NOT logged in, unless someone has hacked me and tries to play insertgamehere at certain times, without me noticing anything in the time I've played or anything like that, and keeps trying to log in over and over and over, always typing in the password and re-logging in before i can reconnect to the server somehow, not mentioning that I'm definitely logged in and it doesn't give me the option to relog, and I already launched the game without incident. Oh, and I'm so tightass with my password that I make up entirely new passwords with both numbers/letters, minimum ~10 letters and I make sure they aren't related to something someone might be able to guess (like something like "ilovetf2" or something else easily guessable).
    It's happened on 2 computers, and I've [made sure the other computers were turned off, using various means] to make sure I'm not logged in on another computer. Also, of the 3 computers I use, 1 has a different internet connection to the others.

    SOMEONE FUCKING HELP ITS SERIOUSLY PISSING ME OFF.
     
  2. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Have you tried choosing a new password? Are any of the other computers you used in offline-mode?
     
  3. Numerous

    Numerous L4: Comfortable Member

    Messages:
    150
    Positive Ratings:
    72
    Yes, changed password before, didn't solve the problem. No, none of the other computers I used are in offline-mode.
     
  4. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    I'd contact Steam support at this point.
     
  5. drp

    aa drp

    Messages:
    2,254
    Positive Ratings:
    2,555
    happened to me once yesterday, hit the 'login' button, and off it went in to the server. could it be the some of your ports are not forwarded?
     
  6. gamemaster1996

    gamemaster1996 L13: Stunning Member

    Messages:
    1,065
    Positive Ratings:
    131
    Doubt it's the games i would say contact steam but i advise telephone as they never listen.
     
  7. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Contact the always helpful steam support.
     
  8. Numerous

    Numerous L4: Comfortable Member

    Messages:
    150
    Positive Ratings:
    72
    Seeing as it only happens some of the time, then I doubt it. I can switch games, and I can join a server, but if I switch back to the original game, the error comes back.