Error Loading Map?

Discussion in 'Mapping Questions & Discussion' started by P1x3lF3v3r, May 30, 2014.

  1. P1x3lF3v3r

    P1x3lF3v3r L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Okay, I'm new at this. I am trying to make a CTF Map. I have a Red Spawnroom and a door which SHOULD WORK. I have been looking through the console code. There are a few problemos (Resupply not binded to prop_dynamic ect.) But I cant move. When I fire, it leaves a black shadow and all I can see is the sky (before It gets covered by the the black shadow.) My map is missing. Cant see a thing. (But can fire weapons? :O) Here is the code of when I spawned as scout.

    Code:
    ] map The_First
    Network: IP 192.168.0.4, mode MP, dedicated No, ports 27015 SV / 27005 CL
    env_cubemap used on world geometry without rebuilding map. . ignoring: tile/floor_tile_001a
    env_cubemap used on world geometry without rebuilding map. . ignoring: vehicle/metaltrain001a
    Using map cycle file 'cfg/mapcycle_default.txt'.  ('cfg/mapcycle.txt' was not found.)
    Error! Variable "$rimlight" is multiply defined in material "models/weapons/c_items/c_usp"!
    Error! Variable "$rimlightexponent" is multiply defined in material "models/weapons/c_items/c_usp"!
    Set motd from file 'cfg/motd_default.txt'.  ('cfg/motd.txt' was not found.)
    Set motd_text from file 'cfg/motd_text_default.txt'.  ('cfg/motd_text.txt' was not found.)
    func_regenerate(locker_regen_red_1) tried to use associated model named 'locker_regen_red_1', but it isn't a dynamic prop.
    'listenserver.cfg' not present; not executing.
    'The_First.cfg' not present; not executing.
    
    Team Fortress
    Map: The_First
    Players: 1 / 24
    Build: 2234230
    Server Number: 1
    
    The server is using sv_pure 0.  (Enforcing consistency for select files only)
    Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/sky_hydro_01rt)
    Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/sky_hydro_01bk)
    Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/sky_hydro_01lf)
    Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/sky_hydro_01ft)
    Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/sky_hydro_01up)
    Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/sky_hydro_01dn)
    Connection to game coordinator established.
    tf_server_identity_account_id not set; not logging into registered account
    Received 2186714 bytes item schema version C68C10D0 direct data; update is queued.
    Detail prop model models/props_lights/hangingbulb.mdl is using vertex-lit materials!
    It must use unlit materials!
    Detail prop model models/props_spytech/bench001a.mdl is using vertex-lit materials!
    It must use unlit materials!
    P1x3l F3v3r connected
    Compact freed 507904 bytes
    JOY_AXIS_X:  mapped to Turn (absolute)
    JOY_AXIS_Y:  mapped to Look (absolute)
    JOY_AXIS_Z:  unmapped
    JOY_AXIS_R:  mapped to Forward (absolute)
    JOY_AXIS_U:  mapped to Side (absolute)
    JOY_AXIS_V:  unmapped
    Advanced Joystick settings initialized
    Redownloading all lightmaps
    func_regenerate(locker_regen_red_1) tried to use associated model named 'locker_regen_red_1', but it isn't a dynamic prop.
    Achievements disabled: cheats turned on in this app session.
    'scout.cfg' not present; not executing.
    Bad SetLocalOrigin(-201.846100,282.175323,-19934.427734) on tf_projectile_cleaver
    Ignoring unreasonable position (4956.105469,700.153748,-20741.880859) from vphysics! (entity tf_projectile_stun_ball)
    Ignoring unreasonable position (5108.115234,712.261353,-30362.455078) from vphysics! (entity tf_projectile_stun_ball)
    func_regenerate(locker_regen_red_1) tried to use associated model named 'locker_regen_red_1', but it isn't a dynamic prop.
    
    I tried to follow this tut, but...https://developer.valvesoftware.com/wiki/TF2/Creating_a_Spawnroom

    Could you please help?
     
  2. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,739
    First up: there's no information in the tf2 console usually, if anything we would need the compile log (all that text hammer spits out when you compile) Any errors will be in there.

    It sounds like you're spawning into the void (the void gives you the hall of mirrors effect which is causing the shadow from firing), which probably means you're spawning at 0,0,0 because you don't have an info_player_teamspawn entity in your map, or if you do, it's inside some geometry and isn't active. info_player_teamspawn entities need to be roughly 16 units above the ground.

    If that doesn't work, post a picture of your room from hammer
     
  3. P1x3lF3v3r

    P1x3lF3v3r L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Ok will do. Altough, I have 16 red playerspawns but no blue. I also have them lifted a bit off the ground. I will recomplie and post.
     
  4. P1x3lF3v3r

    P1x3lF3v3r L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    [original code originally here, found there was a leak, fixing...]
     
    Last edited: May 31, 2014
  5. P1x3lF3v3r

    P1x3lF3v3r L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    OK. I cant pinpoint the leak, as there is no .lin file, and tf2 closes when I try to load the map through the console. Anything else that could help?
     
  6. P1x3lF3v3r

    P1x3lF3v3r L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Code:
    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf" "c:\users\user\desktop\map\the_first"
    
    Valve Software - vbsp.exe (May 15 2014)
    2 threads
    materialPath: C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf\materials
    Loading c:\users\user\desktop\map\the_first.vmf
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    Patching WVT material: maps/the_first/brick/blendcobbletocobblesnow001_wvt_patch
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    **** leaked ****
    Processing areas...done (0)
    Building Faces...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    done (0)
    Creating default LDR cubemaps for env_cubemap using skybox materials:
       skybox/sky_hydro_01*.vmt
     ! Run buildcubemaps in the engine to get the correct cube maps.
    Creating default HDR cubemaps for env_cubemap using skybox materials:
       skybox/sky_hydro_01*.vmt
     ! Run buildcubemaps in the engine to get the correct cube maps.
    Finding displacement neighbors...
    Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...
    done (0) (4472 bytes)
    Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
    Compacting texture/material tables...
    Reduced 101 texinfos to 26
    Reduced 16 texdatas to 10 (389 bytes to 243)
    Writing c:\users\user\desktop\map\the_first.bsp
    0 seconds elapsed
    
    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf" "c:\users\user\desktop\map\the_first"
    
    Valve Software - vvis.exe (May 15 2014)
    2 threads
    reading c:\users\user\desktop\map\the_first.bsp
    reading c:\users\user\desktop\map\the_first.prt
    LoadPortals: couldn't read c:\users\user\desktop\map\the_first.prt
    
    
    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf" "c:\users\user\desktop\map\the_first"
    
    Valve Software - vrad.exe SSE (May 14 2014)
    
          Valve Radiosity Simulator     
    2 threads
    [Reading texlights from 'lights.rad']
    [34 texlights parsed from 'lights.rad']
    
    Loading c:\users\user\desktop\map\the_first.bsp
    No vis information, direct lighting only.
    Setting up ray-trace acceleration structure... Done (0.00 seconds)
    47 faces
    22399 square feet [3225488.00 square inches]
    0 Displacements
    0 Square Feet [0.00 Square Inches]
    3 direct lights
    BuildFacelights:     0...1...2...3...4...5...6...7...8...9...10 (0)
    Build Patch/Sample Hash Table(s).....Done<0.0000 sec>
    FinalLightFace:      0...1...2...3...4...5...6...7...8...9...10 (0)
    FinalLightFace Done
    Computing detail prop lighting : 0...1...2...3...4...5...6...7...8...9...10
    0 of 0 (0% of) surface lights went in leaf ambient cubes.
    ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (1)
    Writing leaf ambient...done
    Ready to Finish
    
    Object names       Objects/Maxobjs  Memory / Maxmem  Fullness 
    ------------       ---------------  ---------------  -------- 
    models                   8/1024          384/49152    ( 0.8%) 
    brushes                 29/8192          348/98304    ( 0.4%) 
    brushsides             182/65536        1456/524288   ( 0.3%) 
    planes                 176/65536        3520/1310720  ( 0.3%) 
    vertexes                67/65536         804/786432   ( 0.1%) 
    nodes                   73/65536        2336/2097152  ( 0.1%) 
    texinfos                26/12288        1872/884736   ( 0.2%) 
    texdata                 10/2048          320/65536    ( 0.5%) 
    dispinfos                0/0               0/0        ( 0.0%) 
    disp_verts               0/0               0/0        ( 0.0%) 
    disp_tris                0/0               0/0        ( 0.0%) 
    disp_lmsamples           0/0               0/0        ( 0.0%) 
    faces                   47/65536        2632/3670016  ( 0.1%) 
    hdr faces                0/65536           0/3670016  ( 0.0%) 
    origfaces               37/65536        2072/3670016  ( 0.1%) 
    leaves                  82/65536        2624/2097152  ( 0.1%) 
    leaffaces               47/65536          94/131072   ( 0.1%) 
    leafbrushes             11/65536          22/131072   ( 0.0%) 
    areas                    1/256             8/2048     ( 0.4%) 
    surfedges              336/512000       1344/2048000  ( 0.1%) 
    edges                  187/256000        748/1024000  ( 0.1%) 
    LDR worldlights          3/8192          264/720896   ( 0.0%) 
    HDR worldlights          0/8192            0/720896   ( 0.0%) 
    leafwaterdata            0/32768           0/393216   ( 0.0%) 
    waterstrips              0/32768           0/327680   ( 0.0%) 
    waterverts               0/65536           0/786432   ( 0.0%) 
    waterindices             0/65536           0/131072   ( 0.0%) 
    cubemapsamples           0/1024            0/16384    ( 0.0%) 
    overlays                 0/512             0/180224   ( 0.0%) 
    LDR lightdata         [variable]        3696/0        ( 0.0%) 
    HDR lightdata         [variable]           0/0        ( 0.0%) 
    visdata               [variable]           0/16777216 ( 0.0%) 
    entdata               [variable]        6169/393216   ( 1.6%) 
    LDR ambient table       82/65536         328/262144   ( 0.1%) 
    HDR ambient table       82/65536         328/262144   ( 0.1%) 
    LDR leaf ambient        71/65536        1988/1835008  ( 0.1%) 
    HDR leaf ambient        82/65536        2296/1835008  ( 0.1%) 
    occluders                0/0               0/0        ( 0.0%) 
    occluder polygons        0/0               0/0        ( 0.0%) 
    occluder vert ind        0/0               0/0        ( 0.0%) 
    detail props          [variable]           1/476      ( 0.2%) 
    dtl prp lght          [variable]           1/4        (25.0%) 
    HDR dtl prp lght      [variable]           1/4        (25.0%) 
    static props          [variable]           1/12       ( 8.3%) 
    pakfile               [variable]      106114/0        ( 0.0%) 
    physics               [variable]        4472/4194304  ( 0.1%) 
    physics terrain       [variable]           2/1048576  ( 0.0%) 
    
    Level flags = 0
    
    Total triangle count: 94
    Writing c:\users\user\desktop\map\the_first.bsp
    1 second elapsed
    
    ** Executing...
    ** Command: Copy File
    ** Parameters: "c:\users\user\desktop\map\the_first.bsp" "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf\maps\the_first.bsp"
    
    
    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\hl2.exe"
    ** Parameters: -dev -console -allowdebug -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf" +map "the_first"
    
    
     
  7. P1x3lF3v3r

    P1x3lF3v3r L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Problem solved

    I got the problem solved, thanks for all the help. The problem was badly placed team_playerspawn's and a leak which accured from badly rotating brushes. Thanks again for the tips. :rolleyes: