Cubemap error!

Discussion in 'Mapping Questions & Discussion' started by suzzanuzza, Jun 6, 2009.

  1. suzzanuzza

    suzzanuzza L1: Registered

    Messages:
    44
    Positive Ratings:
    1
    I keep getting these annoying errors every time i run my map. it prevents the cubemaps from working properly and now i have all those stupid purple and black checkers everywhere. I tried deleting my cubemaps and replacing them with new ones but i still get the errors.

    When the map starts, i have a bunch of these errors:

    failed, using default cubemap 'engine/defaultcubemap'
    failed, using default cubemap 'engine/defaultcubemap'
    failed, using default cubemap 'engine/defaultcubemap'
    failed, using default cubemap 'engine/defaultcubemap'



    Then after i "build cubemaps", I get an error that has to do with the skybox. And i still have the checkers:

    ***Error: Skybox vtf files for sky_night_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file sky_night_01 to build the default cubemap!


    It does this with every skybox texture i try so i dont think its a problem with sky_night_01.
     
  2. l3eeron

    l3eeron L8: Fancy Shmancy Member

    Messages:
    594
    Positive Ratings:
    85
    if your map is working fine then it can be ignored.

    If you still have the checkers after you reload the map, then you need to do the steps again.
     
  3. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    That is, you can ignore the "skybox" error.

    However, the purple and black checkers are still a problem.

    Are you following this sequence?

    load the map
    mat_specular 0
    buildcubemaps
    disconnect
    reload the map
    mat_specular 1

    There's more steps for HDR, but for an LDR map, that should do you.
     
  4. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    146
    You will ALWAYS get this, its Valve's fault:

    ***Error: Skybox vtf files for sky_night_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file sky_night_01 to build the default cubemap!

    V Take a look at V
     
  5. suzzanuzza

    suzzanuzza L1: Registered

    Messages:
    44
    Positive Ratings:
    1
    Cameron:D: your guide gives different instructions than the ones listed above by Pianodan. So which one of you is right?

    also how do i know if my map is HDR or LDR?
     
    Last edited: Jun 7, 2009
  6. sbrown

    sbrown L1: Registered

    Messages:
    40
    Positive Ratings:
    6
    tf2 has no default cubemaps, ignore this and compile cubemaps with specular off
     
  7. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    If you didn't compile it with the "HDR" option checked, it's not HDR. If you're not sure, build the LDR cubemaps as above, run the map, and set your options (via the game control panel) to display HDR if available. If you're getting the purple cubes in HDR mode but not LDR mode, then the map is HDR.

    And it definitely is important to build the cubemaps with specular reflections off.
     
  8. suzzanuzza

    suzzanuzza L1: Registered

    Messages:
    44
    Positive Ratings:
    1
    entering "mat_specular 0" and "buildcubemaps" seems to have fully fixed the problem so are the rest of the steps even necessary?
     
  9. eXeC

    eXeC L1: Registered

    Messages:
    37
    Positive Ratings:
    1
    Well you want to do "mat_specular 1" and reload the map after building the cubemaps or you wont see your pretty new cubemaps in action.

    The rest of the steps are optional but if you compiled with the hdr box ticked then you should build cubemaps for hdr too.