Cube maps don't working with full compile?

Discussion in 'Mapping Questions & Discussion' started by temion, Mar 22, 2010.

  1. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    Cube maps don't work with full compile?

    I've hit an odd problem. If i do a fast compile of my map and then build cube maps, they work great. However if I do a full compile and then build cube maps... nothing happens. They aren't applied.

    Any thoughts as to what is causing this?
     
    Last edited: Mar 22, 2010
  2. The Political Gamer

    aa The Political Gamer

    Messages:
    4,468
    Positive Ratings:
    1,682
    http://developer.valvesoftware.com/wiki/Cubemaps#Building

    Or you could use this: http://forums.tf2maps.net/showthread.php?t=9767
     
  3. Cynick

    Cynick L4: Comfortable Member

    Messages:
    153
    Positive Ratings:
    144
    Cubemaps for non-HDR compiles:
    Code:
    sv_cheats 1
    mat_specular 0
    buildcubemaps
    mat_specular 1
    map <yourmapname>
    Cubemaps for HDR Compiles
    Code:
    sv_cheats 1
    mat_specular 0
    mat_hdr_level 2
    buildcubemaps
    mat_hdr_level 0
    buildcubemaps
    mat_specular 1
    map <yourmapname>
    EDIT: Ninja'd :(
     
    Last edited: Mar 22, 2010
  4. honeymustard

    honeymustard L9: Fashionable Member

    Messages:
    698
    Positive Ratings:
    273
    Sometimes I find I have to load another map, then load your map back in for them to show up.
     
  5. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    Yep i do everything just like written above. However it doesn't work on a full compile, but only on a fast compile. Odd....