Can't build cubemaps

Discussion in 'Mapping Questions & Discussion' started by Ultimate Bread, Jan 12, 2013.

  1. Ultimate Bread

    Ultimate Bread L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    Sup, I am new around here but not new to mapping, recently I started to create a control points map so I can get started with Hammer, the thing is, when I want to build the cube maps, they don't build at all, I have tried different ways, none works, still the purple checkered thing.

    I checked, there's no leak on the skybox.

    Anyone can help?
     
  2. Wander

    Wander L3: Member

    Messages:
    148
    Positive Ratings:
    42
    Do you you have env_cubemap entities in your map? Running the console commands isn't all that's needed, you need to place env_cubemap entities around your map as well
     
  3. Ultimate Bread

    Ultimate Bread L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    I only have 1 due to my map's size, but yes, I do.
     
  4. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,034
    Positive Ratings:
    3,989
    Are you disabling specularity first?

    These should be the commands you put into the console:

    mat_specular 0
    map mapname
    buildcubemaps
    disconnect
    mat_specular 1
    map mapname


    If you don't disable specularity first, you just build reflections that reflect the broken reflection texture.
     
    Last edited by a moderator: Jan 12, 2013
  5. Ultimate Bread

    Ultimate Bread L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    That's the "formula" I use to build the cubemaps, just now I tried placing more env_cubemaps entities but still the areas that are supposed to be alright aren't.
     
  6. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,034
    Positive Ratings:
    3,989
    You're not changing the file name or using the bsp in the sourcesdk_content folder, are you?

    If not, make sure you're following those steps exactly. This works 100% of the time. You are also sure you don't have a leak?
     
  7. Ultimate Bread

    Ultimate Bread L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    I'm not using any bsp and my .vmf file is named "sdk_cp_cargo"

    Tell me if there's something wrong.
     
  8. henke37

    aa henke37

    Messages:
    1,912
    Positive Ratings:
    446
    I think that you forgot to reload the level after building the cubemaps.
     
  9. Ultimate Bread

    Ultimate Bread L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    I always do that, still no change on the cubemaps.
     
  10. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,034
    Positive Ratings:
    3,989
    What do you mean, you're not using any bsp? You're compiling the map, launching TF2 and typing map sdk_cp_cargo, right? That means you're using a bsp.

    I've seen people have bizarre problems when their map uses the sdk_ prefix, and I doubt it's your issue, but you shouldn't be doing that. Use name extensions like _a1, _a2 to denote newer versions you're working on rather than lumping all working copies into sdk_.
     
  11. Ultimate Bread

    Ultimate Bread L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    Well, I also tried using only cp_cargo prefix, no luck neither, this is somewhat driving me off because I don't see anything wrong or bad with the map and still I can't compile the cube maps.
     
  12. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,034
    Positive Ratings:
    3,989
  13. Ultimate Bread

    Ultimate Bread L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    When I do Alt + P I get a list of problems that my map contains, nothing regarding the cubemaps though, just things about some wrong keywords that I already fixed.

    About the log, here's the error:

    You have entered a skybox texture which doesn't seem to be valid. Make sure you don't specify the last three letter (_UP, _DN, etc) of any skybox texture you use. You may also need to fix your vmt files if they are broken. It may also be caused by compiling a non-HDR skybox texture.

    The skybox name I am using is sky_tf2_04
     
  14. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    That error is benign, you can ignore it. What exactly shows up after alt-p? There's a possibility something in your map is blocking cubemaps.
     
  15. Ultimate Bread

    Ultimate Bread L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    The only thing that shows up by now is that there isn't a "Player start", I used the fix button to fix everything else.
     
  16. Shanghai

    Shanghai L6: Sharp Member

    Messages:
    394
    Positive Ratings:
    217
    Give this a shot: Copy everything (ctrl + a, then ctrl + c) into a new vmf, then save and compile that (with cp_ prifix just in case it matters).
     
  17. Ultimate Bread

    Ultimate Bread L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    Stays the same :/
     
  18. Wander

    Wander L3: Member

    Messages:
    148
    Positive Ratings:
    42
    Are you running the game in a decent resolution? I believe it needs to be at least 800x600 for cubemaps to be created (I can't really imagine people still using lower than that, but worth a shot)


    Also, the reason you think the cubemaps aren't built is because you see purple checkered things
    Do you see these purple checkers on reflecting materials such as water and glass? Or on some custom model, in which case cubemaps aren't the problem, but a missing material is?
     
  19. Ultimate Bread

    Ultimate Bread L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    I run the game at 1440x900 if I am not wrong so there's no problem on that, and on some reflective textures I see like a purple checkered reflection and on other textures I see a purple colored reflection too.
     
  20. Wander

    Wander L3: Member

    Messages:
    148
    Positive Ratings:
    42
    Go to steamapps/username/team fortress 2/tf/maps, rightclick your map and go to properties and make sure that it is not for whatever magical reason set to read-only

    You could also try installing TF2 Beta, copy the .bsp file in the folder I just mentioned to the tf2 beta maps folder and build the cubemaps there, to make sure you don't have any tf2 settings that ruin it