Broken Model from L4D2 in TF2

Discussion in 'Mapping Questions & Discussion' started by Motanum, Feb 11, 2011.

  1. Motanum

    Motanum L2: Junior Member

    Messages:
    53
    Positive Ratings:
    13
    Hello, I extracted a model from L4D2.vkp using GCScape. I copied 6 files from the models/props_vehicles. I need the helicoter_rescue model.

    I also copied the helicopter materials (materials/models/props_vehicles/helicopter_rescue.vmt and helicopter_rescue.ctf)

    Here is the catch. The texture works exept for the windows. As it is using some other refleflective glass. And the animation is also broken, when I load the model it also shows up vertically, instead of horizontally.

    I would like to have the animations fixed, so that it looks like it is staying in the air properly, with it's blades spinning. How ever, more critically I need to fix the windows, as they show up pink and purple. Can anyone tell me how I can know what material I need to crate/copy for the windows? As in, how can I know which files the .mdl is looking for?

    I can provide with pictures if needed, however, I need to go to class in 5 minutes, so I am going to pack this up.

    Please respond. :p

    With love
    Motanum!
     
  2. Mick-a-nator

    aa Mick-a-nator

    Messages:
    640
    Positive Ratings:
    314
    The pink windows should be fine in the map. Pink checks mean the texture associated with it wasn't found. In this case, the reflections are missing. simply compile the map and build cubemaps and this should be fixed.
    As for the orientation, that sounds like the extraction flipped the x and z axis of the model, but I'm not sure why it would do that. I don't know what's up with the animation, sorry.
     
  3. Exist

    Exist L6: Sharp Member

    Messages:
    306
    Positive Ratings:
    112
    These errors are all related to the .qc file. The qc file tells the model what shaders to use (most likely why the glass is pink, l4d2 might have a different way to handle opacity), where the textures are located (again explains the whole pick and black checkers) and where the models animations are located.

    Another plausible explanation is a different MDL version. L4d2 uses a newer source engine and therefore might have a different model compile process.
     
  4. Motanum

    Motanum L2: Junior Member

    Messages:
    53
    Positive Ratings:
    13
    No, I could see windows in L4D2 hammer model and not in TF2 hammer model. I also compiled and launched the game, and no, still pink checkered. Even though I did not build cubemaps, I did have mat_specular turn to 0.

    Well, where can I find the .qc file? It was not under models/prop_vehicle. I will try to pin point that texture in hammer and fix it.

    I also agree with your MDL hypothesis, since I could before extract portal models still with animation working fine.

    (In game pic of working model from Portal)
    http://steamcommunity.com/id/Motanum/screenshot/541759391966615790

    When I launched the game, I realized I got an infinite problem error regarding animations and particles. So, I think I will try to fix the problem by removing animations and simply faking the rotating blades with textures and a flat cylinder.

    I will post results later. For now, I am gonna try to pinpoint that missing texture.