Black on spawn?!

Discussion in 'Mapping Questions & Discussion' started by BaNaNa, Mar 19, 2008.

  1. BaNaNa

    BaNaNa L1: Registered

    Messages:
    28
    Positive Ratings:
    0
    Im working on my map, and starting to test....

    When I spawn all I see is black and my gun. I already pulled all the spawn points off the ground can someone please take a look.

    http://www.megaupload.com/?d=33C4DV0B
     
  2. Paria

    Paria L5: Dapper Member

    Messages:
    202
    Positive Ratings:
    31
    when i try to compile the file i get

    Error: displacement found on a(n) func_detail entity - not supported (entity 158, brush 0)

    after moving that back to world, i then get

    Found a displacement edge abutting multiple other edges.
    Warning: overflowed 23 displacement corner-neighbor lists.Warning: invalid neighbor connection on displacement near (64.00 3200.00 128.00)
    Warning: invalid neighbor connection on displacement near (5.00 3200.00 128.00)
    Warning: invalid neighbor connection on displacement near (-448.00 3200.00 128.00)
    Warning: invalid neighbor connection on displacement near (-448.00 3200.00 128.00)
    Warning: invalid neighbor connection on displacement near (-448.00 3136.00 192.00)
    Warning: invalid neighbor connection on displacement near (64.00 3136.00 192.00)
    Warning: invalid neighbor connection on displacement near (-448.00 3200.00 192.00)
    Warning: invalid neighbor connection on displacement near (-448.00 3200.00 192.00)
    Warning: invalid neighbor connection on displacement near (-128.00 960.00 128.00)
    Warning: invalid neighbor connection on displacement near (-128.00 960.00 64.00)
    Warning: invalid neighbor connection on displacement near (-128.00 1024.00 128.00)
    Warning: invalid neighbor connection on displacement near (-128.00 1024.00 128.00)
    Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...
    Displacement 142 has bad geometry near 176.00 1316.81 -64.00
    Can't compile displacement physics, exiting. Texture is NATURE/DIRTGROUND002

    furthermore you have a big leak in the roof - since you have no skybox and a big gap in-between some of the geometry at -631,710
     
    Last edited: Mar 19, 2008
  3. DrHaphazard

    DrHaphazard L5: Dapper Member

    Messages:
    249
    Positive Ratings:
    12
    First off post the log from your compile. You can actually take it here http://www.interlopers.net/index.php?page=errors and it will tell you what all the errors mean.

    You can also press Alt+P (or Ctrl+P cant remember and cant open source) to see all the problems with your map.

    Finally make sure your spawn points are not touching the floor. That will mess up a lot of things if they are touching the floor.
     
  4. BaNaNa

    BaNaNa L1: Registered

    Messages:
    28
    Positive Ratings:
    0
    thanks for the help guys. After I sent it I saw the big hole in the cieling. There is supposed to be another floor on top. (It's going to be like a 2 level dustbowl). My monitor on my computer died, so its going to be a while before I can get that error log analized, but yeah. I did put a func_detail on an object that I put a displacement, I didnt know that I cant do that. Thanks for the help.