A couple of problems with my custom model

Discussion in 'Mapping Questions & Discussion' started by eyefork, Jan 14, 2010.

  1. eyefork

    eyefork L3: Member

    Messages:
    130
    Positive Ratings:
    94
    1. Why is it enormous?! I'm assuming it's the scale value that I missed in the .qc file? Just wanting to confirm before I start messing around and get frustrated.

    2. Where is the texture? It doesn't show up in Hammer or the compiled map. It is just a red 256x256 .vtf.

    Here is my .qc file

    When compiling, my texture and .vmt were located in "C:\Program Files (x86)\Steam\steamapps\username\sourcesdk_content\tf\materialsrc\wineglass" as wineglass_1.vtf and .vmt

    After compiling the model, I copied both files to "C:\Program Files (x86)\Steam\steamapps\username\team fortress 2\tf\materials\wineglass"

    Am I missing something?

    Also, an enjoyable picture of the catastrophe:
    [​IMG]
     
  2. VelvetFistIronGlove

    aa VelvetFistIronGlove

    Messages:
    567
    Positive Ratings:
    437
    1. Yes, "$scale 10" in your .qc means the model will be scaled to 10 times the normal size when loaded in game (normal size usually means 1 unit in your modelling program = 1 unit in hammer).

    2. "$cdmaterials" is the directory for the model's materials, so you should be doing $cdmaterials "wineglass", as the wineglass_1 bit is the material file name.

    Note that you ought to stick model materials under materials/models/<whatever>; it keeps them out of the way when browsing for textures in hammer.
     
    • Thanks Thanks x 1