A confusing situation

Discussion in 'Mapping Questions & Discussion' started by scoots, Oct 11, 2012.

  1. scoots

    scoots L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Hi,

    I've encountered a strange and somewhat confusing situation while play-testing my nigh finished Payload map.

    Currently players(or bots for testing) will only spawn on the one spawn point on the Blu teams base, regardless of what I try this occurs. The only solution to this problem i have found is to change the 'Restrict team from winning' property from "Red" to "neither" in my 'Team_control_point_round' entity. This allows players and bots on both sides to make use of all available re-spawn points.

    This however then causes the map to stop functioning properly as when the last control point is captured the Blu team won't win and the game continues indefinitely despite the giant explosion and the Blu team controlling all points.

    I should state that the game ends correctly if the 'Restrict team from winning' is set to 'Red' on the 'Team_control_point_round' entity.
    I also have to change the 'Restrict team from winning' property in the 'Team_control_point_master' entity to 'Red' to counteract the spawn point fix, otherwise the red team wins the game instantly.


    I've already searched for solutions to the spawn issue and have tried solutions such as raising the spawn points above the ground, ensuring they are within the re-spawn rooms, and there are no nearby obstructions.
    The re-spawn rooms also have their teams correctly set.


    If anyone has a solution or has encountered this before It would be greatly appreciated.

    Cheers
     
  2. henke37

    aa henke37

    Messages:
    1,892
    Positive Ratings:
    443
    Check the round set for the spawn room.
     
    • Thanks Thanks x 1
  3. scoots

    scoots L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    It wasn't the spawn rooms that needed changing it was the spawn points themselves. I just tested it and that worked fine!

    I hadn't realized these needed to be declared for a single round map.

    Cheers for the heads up!