1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

3d Skybox not working for final compile

Discussion in 'Mapping Questions & Discussion' started by necro, Apr 30, 2008.

  1. necro

    necro L3: Member

    Messages:
    106
    Positive Ratings:
    13
    Oh man, this sux. I made a 3dskybox, did a fast vis, and it worked. I cordoned off an area, did a full vis, and it worked. Proceeded to do the lighting with a fast vis, and it worked. Last night, I did what was supposed to be the final compile, and this morning, no skybox was showing in the map! Arrgh!

    I can noclip down to the skybox itself, and all the miniature stuff is there and properly lit. Interestingly, when I'm in the skybox, I can see the scaled up version out where the main map is. But when I'm in the main map, no skybox, just 2d sky.

    Any ideas? I really hate to submit today without the skybox. : (
     
  2. Armadillo of Doom

    aa Armadillo of Doom Group Founder, Lover of Pie

    Messages:
    949
    Positive Ratings:
    615
    Curious. So it worked until you did full lighting compile? Only thing that comes to mind is you're missing light_environment in the 3d box. If you have that, put up some before/after pics.
     
  3. necro

    necro L3: Member

    Messages:
    106
    Positive Ratings:
    13
    light_environment is there. And its not like the skybox is just dark, its just not there.
    Interesting, I did a full vis of the entire map this morning without vrad, and skybox works. So I think vrad is screwing something up. I'll back up my vis'd bsp and mess around with vrad to see if I can fix it. Clock is ticking!
     
  4. necro

    necro L3: Member

    Messages:
    106
    Positive Ratings:
    13
    I think what was causing this is that 1 of the props was peeking above the sky ceiling in the main map. I stretched the sky brushes up and it finally started working.