1. Hey Guest, welcome to the new forums. Be sure to check out this thread to get all the information you need on the cool new stuff!

"map differs from server's..."

Discussion in 'Mapping Questions & Discussion' started by TheFragMan, Jan 16, 2008.

  1. TheFragMan

    TheFragMan L1: Registered

    Messages:
    33
    Thanks Received:
    1
    Not so much a mapping specific question, but during all my testing of my maps on my server, I keep running into this problem and was wondering if you guys have ever had similar issues:

    I finish a beta version of my map, upload it to my server, people play, they give feedback... the usual. After I finish a second, updated beta version (with a new unique file name), I copy it directly from my computer to the server for people to play. BUT, everyone, including me, always gets the dreaded "your map differs from the server's."

    I can't figure it out. It doesn't even work for me even though it's the exact same map on the server and my computer. I've found that the only way I can get around this is by copying all the contents of a map into a new, blank map, and saving that (but that just has it's own issues, especially by messing up overlays).

    So, am I missing something with renaming the map? What do you guys do?
     
  2. YM

    aa YM LVL100 YM

    Messages:
    6,321
    Thanks Received:
    4,715
    You are probably calling it the same name as the fist beta, and as source dosn't like overwriting its seeing cp_yourmap in the team fortress 2/tf/maps folder and its different to the server's cp_yourmap.
    Thats why all the maps you see have _b1, _b2, _b3.... after them
     
  3. TheFragMan

    TheFragMan L1: Registered

    Messages:
    33
    Thanks Received:
    1
    I've been doing that naming system. cp_yourmap_b1, cp_yourmap_b2, etc. Every time though, without fail, I get the same error.

    The weird thing, though, is a friend can upload his maps to the same server and nobody gets an error, even if it's named the same thing (after deleting the old and re-downloading). He doesn't do anything different than what I do, which doesn't make sense why his works, but not mine.

    By the way, deleting the old version from my maps folder, and re-downloading a fresh copy doesn't help.
     
  4. YM

    aa YM LVL100 YM

    Messages:
    6,321
    Thanks Received:
    4,715
    now thats really wierd
     
  5. TheFragMan

    TheFragMan L1: Registered

    Messages:
    33
    Thanks Received:
    1
    lol, yeah. Welcome to my world of "annoying things that get in the way of my mapping."
     
  6. Snipergen

    Snipergen L13: Stunning Member

    Messages:
    1,013
    Thanks Received:
    150
    bad karma.

    Nah probably just a bug.
     
  7. Fyfey

    Fyfey L2: Junior Member

    Messages:
    51
    Thanks Received:
    4
    When testing maps with my friends on a LAN, we save the map as the same name and host a server... but need to remove the maps out of our tf/maps directory as to not receive the "File differs from server" message.
     
  8. TheFragMan

    TheFragMan L1: Registered

    Messages:
    33
    Thanks Received:
    1
    Well, I put the map up on our rented clan server. And even deleting the old map doesn't stop the error from showing up. And for some reason, it's only me. Friends will send me their maps, and I upload them to the server, and they work fine. But not when I make them.

    Oh and I have tried reinstalling the SDK, twice, still no luck. It's just plain old annoying.
     
  9. Lamech

    Lamech L1: Registered

    Messages:
    18
    Thanks Received:
    8
    I hate to necro this thread, but was this ever resolved? I had a similar problem and I was renaming the maps as well. Come to find out it was a texture I had and the others did not.

    Which brings me to this question, how do other maps pull in custom textures and decals? Is it all saved in the map file or are they like custom sounds? If its the latter I would assume I need to host the map on a server with the custom textures in the right place for them to download as well? Or can this still be done after compiling and running the map in hammer?
     
  10. eerieone

    aa eerieone

    Messages:
    980
    Thanks Received:
    569
    you have to pack everything that is custom into the mapfile .bsp
    everyone uses pakrat for that, it´s a small nifty java-based program that checks your bsp for content and pulls in what is not standard valve-stuff
     
    Lamech thanked this.
  11. Lamech

    Lamech L1: Registered

    Messages:
    18
    Thanks Received:
    8
    Alright thanks, I'll get right on that.
     
  12. shpladoink

    shpladoink L3: Member

    Messages:
    106
    Thanks Received:
    6
    I'm going to bump this thread again, two months later. I'm getting a "map differs from server's" error with my map. However, it is the same exact file in my folder and in the server's maps folder. Everyone (including myself) is getting this error. I'm wondering if it has anything to do with the fact that I've packed a .wav into the map, but I've found that the map works just fine on my and another person's local servers, but not on the actual online gameserver.

    I honestly have no idea what to do with this since I've recompiled, renamed and repacked the map twice and gotten the same result. This map is no good if the only way people can play it is by themselves.
     
  13. Psy

    aa Psy I make maps, but not in Korea.

    Messages:
    1,612
    Thanks Received:
    1,261
    I had a problem when joining the EU server. It began downloading the current map and as soon as it start to send client info it said, "Your map differs from the server's..." :\
     
  14. Cylence

    Cylence L1: Registered

    Messages:
    38
    Thanks Received:
    11
    I have received a similar error. I had my server set up for fast downloading and I think that the .bz2 file on my server was corrupted but the .bz2 on my web host wasn't. I'm not sure though.
     
    Last edited: Mar 24, 2010
  15. Lyra

    Lyra L1: Registered

    Messages:
    44
    Thanks Received:
    43
    I'm going to have to bring back this thread again too. I'm getting the same issue with my map, there's no custom content, or strange output from the compile log, yet every time we try to play it (A friend confirmed this issue occurs on his server as well as here) it inexplicably returns this error for everyone, including me.

    Was a solution ever found?
     
    Last edited: Apr 9, 2012
  16. ics

    ics L5: Dapper Member

    Messages:
    233
    Thanks Received:
    47
    Server doesn't need bz2 packed version of the map, just the bsp. All files will be downloaded from the download host (sv_downuloadurl) if such is used.

    Usually if map differs from servers, there are couple of reasons:

    1. Faulty memory, either your machine or server. Can corrupt map download or on file transfer.
    2. Map is different in download host than at the server
    3. IIS (windows hosted) webserver can cause different version due to mime types.

    There could be other reasons too, but these are the most common i know.
     
  17. 1edmund

    1edmund L1: Registered

    Messages:
    1
    Thanks Received:
    0
    I am also having the same problem

    But my problem is when i JOIN a ach_remade server it says EXACTLY the same thing pls help:confused: :confused:
     
  18. henke37

    henke37 L13: Stunning Member

    Messages:
    1,144
    Thanks Received:
    216
    Just nuke the maps folder and redownload the map.
     
  19. Little Dude

    Little Dude L4: Comfortable Member

    Messages:
    169
    Thanks Received:
    54
    I think I had this problem once, even when redownloading the map. All I did was after the map finished downloading, I deleted it again and then rejoined the server. I think I remained in game and it still worked though if it doesn't you could give restarting the game a try after you redownload the map.