Working on First Map

Discussion in 'Mapping Questions & Discussion' started by Bumpkin40, Jul 18, 2011.

  1. Bumpkin40

    Bumpkin40 L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    I followed several tutorials on how to make spawn rooms and it seems to mostly work, except when I spawn I do not have any guns and I cannot move. Here is the error list, however, I followed three different guides completely and I got these errors and the one I just mentioned.



    Spawnpoint at (-1536.00 -71.88 72.00) is not clear.
    Spawnpoint at (-1536.00 -14.34 72.00) is not clear.
    Spawnpoint at (-1536.00 42.68 72.00) is not clear.
    Spawnpoint at (-1536.00 -136.00 72.00) is not clear.
    Spawnpoint at (-1440.00 -136.00 72.00) is not clear.
    Spawnpoint at (-1440.00 -71.88 72.00) is not clear.
    Spawnpoint at (-1440.00 -14.34 72.00) is not clear.
    Spawnpoint at (-1440.00 42.68 72.00) is not clear.
    Spawnpoint at (-1352.00 -136.00 72.00) is not clear.
    Spawnpoint at (-1352.00 -71.88 72.00) is not clear.
    Spawnpoint at (-1352.00 -14.34 72.00) is not clear.
    Spawnpoint at (-1352.00 42.68 72.00) is not clear.
    exec: couldn't exec listenserver.cfg
    exec: couldn't exec firstmap.cfg
    ]

    Team Fortress
    Map: firstmap
    Players: 1 / 24
    Build: 4624
    Server Number: 1

    Here are the thee guides I followed
    http://forums.tf2maps.net/showthread.php?t=198
    http://developer.valvesoftware.com/wiki/TF2/Creating_a_Spawnroom
    http://www.youtube.com/watch?v=pKQlHNeU2zs&feature=channel_video_title
     
  2. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    clearly your spawn point at those coordinates are not clear.

    Move the points so they are about 16-32 units above the ground.
     
  3. The Asylum

    aa The Asylum

    Messages:
    1,658
    Positive Ratings:
    439
    the spawnpoint errors are what you get when an info_player_teamspawn is too close to a brush, or intersecting it. Try spacing the spawnpoints out and opening up the spawnroom so they all have some room to breathe. Also, don't out them right onto the floor, you'll want to keep them a bit above.

    the listenserver.cfg isn't important. It's supposed to be a txt fiile that you can save as a .cfg and drop into your tf folder. In it you can put cvars to make testing easier, such as sv_cheats 1, mp_disable_respawntimes 1, etc. It's not essential and won't affect your map
     
  4. Bumpkin40

    Bumpkin40 L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    I tried this and I think they are pretty far apart and it still doesn't work.

    [​IMG]

    I even tried it with 4 spawn points even further apart and it didn't work.

    [​IMG]
     
    Last edited: Jul 18, 2011
  5. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    Remove whatever func_detail that is. You can do this by selecting that brush (or group of brushes) and hit ctrl+shift+w
     
  6. Loc_n_lol

    Loc_n_lol L10: Glamorous Member

    Messages:
    726
    Positive Ratings:
    273
    Yeah looks like you've encased your player spawns into a solid block, of course they're not clear. :)
     
  7. Bumpkin40

    Bumpkin40 L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    That's supposed to be the thing that lets them change classes without dying, how would I get around the stuck part? lol
     
  8. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    What it looks like, you have it set as a func_detail. You want to click that brush and click Ctrl+t, this will open up the brush properties window. in the area where it says func_detail, change it to func_respawnroom. You will also need to texture this brush with the "trigger" texture.