Why does it do this?

Discussion in 'Mapping Questions & Discussion' started by NameUser, Jun 29, 2012.

  1. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    I constantly gets leaks, load the .lin, and end up with a line going straight through a brush. Sometimes straight through the skybox itself. Why? This is incredibly obnoxious and wastes loads of my time.

    (The brushes in question are not func_details)
     
  2. Tarry H Sruman

    Tarry H Sruman Large Orphanage Proprietor

    Messages:
    871
    Positive Ratings:
    820
    Are there things outside of the skybox?
     
  3. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    Yes, but the things the lin is leading from are within it. Not to mention the things outside the skybox are fully contained.
     
  4. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,031
    Positive Ratings:
    3,975
    Are the brushes any kind of entity? Are you compiling with all point entities off? There is a third thing here that I was going to ask and forgot.
     
  5. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    1. Sometimes, but it doesn't matter. It has complete disregard for solid brushes, I just dealt with a case of it going straight through the ground, which was no sort of entity.

    2. No clue. Running normal BSP fast VIS and RAD.
     
  6. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,031
    Positive Ratings:
    3,975
    If you're compiling with zero entities except areaportals, it always leaks for no reason. Compile with at least some point entities in the map.

    If I'm reading your post right.
     
  7. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    It's gorge. It's full of entities.
     
  8. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,031
    Positive Ratings:
    3,975
    I realized in your other thread about the same issue that you wouldn't know what that is. I suggest moving all discussion to that one.
     
  9. Mini Maracas

    Mini Maracas L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    I'm not sure if this is the solution, but is any of the floor terrain? Terrain doesn't prevent leaks.

    Also, try re-making the skybox? Happened to me once, don't know what exactly happened but I remade the skybox and it worked.
    How do you make your skybox? Do you 'make hollow' a block? Or do you make 5 (or 6) seperate brushes with the skybox texture? I prefer the latter option, as it is less buggy, could try that? :)

    Hope I helped. :)
     
  10. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    Issue has been fixed. Thanks for the assistance.
     
  11. RaVaGe

    aa RaVaGe

    Messages:
    723
    Positive Ratings:
    1,020
    When you fix an error by yourself, post the solution ;)
     
  12. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    Didn't really find the solution to this. I found another leak in the map, fixed it, and this stopped. Doesn't explain why it was not telling me about the actual leak in the first place.