White screen issue. Probably related to HUD/Custom Configuration.

Discussion in 'Mapping Questions & Discussion' started by Ninamori, Jun 28, 2015.

  1. Ninamori

    Ninamori L1: Registered

    Messages:
    31
    Positive Ratings:
    6
    Hello. I am trying to work on a map, but whenever I compile, and get in-game the screen is ENTIRELY white. I have a feeling that it has to do with either my custom cfg, or my HUD. I have a some FPS optimized CFG, and transparent viewmodels. Here is the full console log, and you can see a ton of errors.

    As shown here disabling the HUD does seem to let me see, but that is less than optimal. Any ideas?
     
  2. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    931
    Positive Ratings:
    894
    Console logs are generally very useless in mapping. I can't find anything in there that helps.
    The screen appears white because there is something being overlayed on the screen. Are you using any entities that could cause that?
     
  3. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,031
    Positive Ratings:
    3,975
    There's occasionally weird bugs with fullbright maps. You might just want to try adding lighting. Otherwise, disable your HUD while you work on maps.

    Tombulisu is right though: your console log is usually one of the least useful things for troubleshooting. You'd want to look for errors in Hammer's compile log, or press alt+p and check for errors in your map that way.

    From the info I have, I don't know what it is, but I'd blame your custom HUD and stuff.
     
    Last edited: Jun 28, 2015
  4. Ninamori

    Ninamori L1: Registered

    Messages:
    31
    Positive Ratings:
    6
    Well I tried to do join a server, and it seems to be only happening when I try to run the map via Hammer. This is weird.
     
  5. Ninamori

    Ninamori L1: Registered

    Messages:
    31
    Positive Ratings:
    6
    Sorry about bumping this, but I've waited three days, and really just want to find some sort of work around (aside from the one in my OP).

    Is there any sort of launch command that could disable custom content (ie HUDS, and the like)? I think that would work if it is possible.
     
  6. Lampenpam

    aa Lampenpam

    Messages:
    991
    Positive Ratings:
    328
    If you want to disable your HUD or other custom content, just remove them from your tf folder. Wasn't that simple?
     
  7. Ninamori

    Ninamori L1: Registered

    Messages:
    31
    Positive Ratings:
    6
    Sadly not as I want to have my transparent viewmodels which requires a customized HUD, and disabling the HUD doesn't work as it is tied into a CFG modification.
     
  8. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,031
    Positive Ratings:
    3,975
    This sounds like all your fault, not Hammer's. You're going to have to remove your custom configs while compiling. That's really it, I'm afraid.

    sv_pure 2 might work, but I doubt it.
     
  9. Hergan5

    Hergan5 L1: Registered

    Messages:
    27
    Positive Ratings:
    4
    I think the transparent viewmodels are the problem, they're using a refract material to make itself transparent, that's why the texture is on the whole screen. Are you running on DX8 actually?
     
  10. Ninamori

    Ninamori L1: Registered

    Messages:
    31
    Positive Ratings:
    6
    Well I figured out a workaround that will have to do. I placed my transparent viewmodels file as well as the HUD file into a folder named "DO NOT LOAD" so TF2 won't be able to find them. I opened up Notepad++, and put "**VOID**" next to the commands that make the CFG work with the HUD, and bookmarked them (Notepad++ is awesome btw).

    Anyway this is not optimal, but is a side effect of wanting to use fancy-ish viewmodel displays. Cheers.