Weird lightning bug with displacement cliffs?

Discussion in 'Mapping Questions & Discussion' started by Darkyy, Feb 16, 2015.

  1. Darkyy

    Darkyy L1: Registered

    Messages:
    4
    Positive Ratings:
    1
    I worked a bit with displacement cliffs for my map and I encountered a weird and ugly lightning bug http://i.imgur.com/9CymEcz.jpg.

    The displacements are also sewed and I dont really know how fix this. Even after reworking the whole cliff around 3 times I still ended up with this. The upper texture is blendgroundtograss007_reducedetail and the lower one is blendrockgroundwallforest_reducedetail. Both have the same texture settings.

    Might be nice if someone could tell me whats wrong.
     
  2. Pocket

    aa Pocket func_croc

    Messages:
    4,479
    Positive Ratings:
    2,211
    You're talking about how to remove the visible hard edge? Try using smoothing groups. If there's a sharp edge phyiscally, then the compiler will assume it's that way on purpose and light it the way a sharp edge would be lit in real life. And make sure the lightmaps line up — click the "camera" button in the top left of the 3D view and select "3D Lightmap Grid" to check.
     
    • Thanks Thanks x 1
  3. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,739
    It's either one of two things:

    1) The edges are over 45 degrees and aren't getting smoothed, make the join rounder.
    2) The wall texture has an SSBump rather than a normal map, in which case you're screwed. SSBumps make the whole texture paler and matching them up with non SSBumped textures is next to impossible.