Weird lighting bug

Discussion in 'Mapping Questions & Discussion' started by MegapiemanPHD, Oct 6, 2016.

  1. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    1,006
    Positive Ratings:
    497
    So this one is really odd. I've got 2 brushes next to each other that both use the same texture, wall 128x128. For some unknown reason one of the brushes is darker than the other one. This bug persists even if I put a light over in that area. Does anyone have any ideas?
     

    Attached Files:

  2. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    1,006
    Positive Ratings:
    497
    Anyone have any ideas how to fix this?
     
  3. Malachite Man

    Malachite Man L6: Sharp Member

    Messages:
    310
    Positive Ratings:
    152
    do they both have the same lightmap grid scale?
     
  4. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    1,006
    Positive Ratings:
    497
    I don't know what that means. They are both the same texture and are both func_detail if that's what you mean.
     
  5. Malachite Man

    Malachite Man L6: Sharp Member

    Messages:
    310
    Positive Ratings:
    152
    upload_2016-10-7_13-37-46.png
    go to camera and put lightmap gird if the lightmap grid is not the same then light cast diffrent quality of lights there you can change lightmaps grids by going to the face editor upload_2016-10-7_13-39-45.png
    And where it says lightmap grid you can adjust it this page should help you better understand https://developer.valvesoftware.com/wiki/Lightmap
     
  6. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    1,006
    Positive Ratings:
    497
    The lightmap grid was the same for both brushes. After changing them from func_detail to func_lod that seems to have fixed the issue.
     
  7. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    1,006
    Positive Ratings:
    497
    That brings up the unintentional issue of stickybombs not sticking to those entities :/
     
  8. Another Bad Pun

    Server Staff Another Bad Pun punished nerd

    Messages:
    594
    Positive Ratings:
    1,284
    More than likely, vvis is cutting a visleaf in that spot due to the fact that your garage door next to it is slightly indented. Visleafs can cause lighting cuts like this regardless of light map alignment.

    The func_lod working is probably due to the entity getting its light source from the origin. The func_detail didn't change the cutting of visleaf in a way that fixed the lighting.

    I would try readjusting some hints to see if that fixes it. Maybe put a hint flush over the door and that entire wall.
     
    Last edited: Oct 7, 2016
  9. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    1,006
    Positive Ratings:
    497
    That whole group of brushes are all func_detail and aren't cutting vis.
     
  10. Another Bad Pun

    Server Staff Another Bad Pun punished nerd

    Messages:
    594
    Positive Ratings:
    1,284
    The hallway you have creates a T-junction and so it will happen regardless
     
    • Agree Agree x 1