Water texture upside down in TF2

Discussion in 'Mapping Questions & Discussion' started by FernandoWhitmore, Jan 28, 2016.

  1. FernandoWhitmore

    FernandoWhitmore L1: Registered

    Messages:
    19
    Positive Ratings:
    2
    Is there a trick to water? I made a nodraw brush with the top surface as water/water_2fort but in game the "water surface" is drawn inside the brush - water from above is invisible and every brush behind it gets culled from view until I go in the water.

    There're are no leaks or errors (for once) in the compile log, but it's saying there's no vis information - I've temporarily make most of the world brushes into detail entities until I get round to portalling this monstrosity but a few brushes are still structural
     
  2. Davekillerish

    aa Davekillerish Lvl O: Orange Member

    Messages:
    1,430
    Positive Ratings:
    794
    The player clip brush deosnt work, you have to use the nodraw texture for all sides except the top. If players arent ment to go into the water, use a player clip brush on top of it, or a trigger_hurt to kill them
     
  3. FernandoWhitmore

    FernandoWhitmore L1: Registered

    Messages:
    19
    Positive Ratings:
    2
    sorry, i meant nodraw
     
  4. FernandoWhitmore

    FernandoWhitmore L1: Registered

    Messages:
    19
    Positive Ratings:
    2
    Does it need a surface below it? Right now there's just the bottom brush of the skybox beneath it - just a floating brush
     
  5. Vel0city

    aa Vel0city func_fish

    Messages:
    1,900
    Positive Ratings:
    1,512
    No vis information, no water. It's that easy. You need VVIS to run on at least the -fast setting in order for water to work, and even that can cause issues.

    Also, make sure that your nodraw bush covered in water goes all the way trough the ground. Make sure that there aren't any gaps between the ground a player is walking on and the water brush above it.
     
    • Thanks Thanks x 1
  6. FernandoWhitmore

    FernandoWhitmore L1: Registered

    Messages:
    19
    Positive Ratings:
    2
    vis was on fast - wasn't getting any vis information because I made the skybox detail too - I'm not even sure how it could compile that, but that's fixed

    Brought the clip to the bottom and it seems to be working great - just some mild lighting errors. Cheers
     
  7. henke37

    aa henke37

    Messages:
    1,855
    Positive Ratings:
    430
    Remember to put a bottom on the water area or else people might fall out.
     
    • Like Like x 1