Water is not rendered

Discussion in 'Mapping Questions & Discussion' started by Nimelrian, Jul 31, 2010.

  1. Nimelrian

    Nimelrian L2: Junior Member

    Messages:
    64
    Positive Ratings:
    6
    Hey guys,

    i've got a problem (again :rolleyes:). I'm making a small tunnel of displacements and a small part of the ground should be filled with water.

    The problem is, that i can hear the water sounds while walking over it and the splashes which are created by shooting at it are visible, but the water itself is invisible.

    [​IMG]

    [​IMG]

    Thanks in advance!

    Nim
     
    Last edited: Jul 31, 2010
  2. StickZer0

    aa StickZer0 💙💙💃💙💙

    Messages:
    664
    Positive Ratings:
    667
    Are you running VVIS at all when compiling?

    Also are you sure you're using a working water texture?
     
  3. Nimelrian

    Nimelrian L2: Junior Member

    Messages:
    64
    Positive Ratings:
    6
    Vis is running on "normal", the texture is water_2fort.
     
  4. Mick-a-nator

    aa Mick-a-nator

    Messages:
    640
    Positive Ratings:
    314
    Sounds like you have a leak. Try loading the point file to see where it is.
     
  5. Nimelrian

    Nimelrian L2: Junior Member

    Messages:
    64
    Positive Ratings:
    6
    There is no leak as there is no point file. I tried this already.
     
  6. Mr.Late

    Mr.Late L7: Fancy Member

    Messages:
    408
    Positive Ratings:
    151
    Try other water textures and make sure only top face have water texture on it.
     
  7. Nimelrian

    Nimelrian L2: Junior Member

    Messages:
    64
    Positive Ratings:
    6
    I tried it with water_2fort, doublecross, hydro and well, or short: All water textures of TF2
     
  8. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,818
    Positive Ratings:
    4,660
    Is the brush nodraw on all other sides?
     
  9. Nimelrian

    Nimelrian L2: Junior Member

    Messages:
    64
    Positive Ratings:
    6
    Yep, it is.
     
  10. Da sapoik dude

    Da sapoik dude L1: Registered

    Messages:
    10
    Positive Ratings:
    3
    Tie the water brush to a func_water_analog entity

    Let us know if it does not work.
     
    Last edited: Jul 31, 2010
  11. Nimelrian

    Nimelrian L2: Junior Member

    Messages:
    64
    Positive Ratings:
    6
    Thanks, that fixed it!

    Nim
     
  12. Da sapoik dude

    Da sapoik dude L1: Registered

    Messages:
    10
    Positive Ratings:
    3
    You're welcome ;)
     
  13. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    If that looks good, go for it, but I think it's addressing the symptom rather than the cause.

    In TF2, there are two kinds of water. "Expensive" (like in 2fort) where you have ripples and refraction. Then there's "cheap" water, which has no ripples and is "flatter". By using func_water_analog, you're forcing it into cheap-mode.

    Due to some engine limitations, you cannot have two bodies of expensive water that (A) have different surface-heights (B) can be seen at the same time from a spot in your map.

    Make sure all your water has the same surface height, or ensure that your map (may require using hint brushes) is set up so that nobody can see both of them at once.
     
  14. Dr. Spud

    aa Dr. Spud Grossly Incandescent

    Messages:
    878
    Positive Ratings:
    800
    That still wouldn't make the water completely invisible like that. It would just have screwy reflections.
     
  15. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Post the compile log when it isn't water_analog.