vtex.exe Errors

Discussion in 'Mapping Questions & Discussion' started by Verno, Jun 29, 2013.

  1. Verno

    Verno L2: Junior Member

    Messages:
    80
    Positive Ratings:
    32
    So I have been following Nineaxis's Making a Poster Overlay instructions on how to convert my files to VTF, but when I drag and drop to vtex.exe I get these errors (I orginal got a different error, but it has since evolved into these errors instead.)

    [​IMG]

    Any help would be appreciated.
     
  2. Shanghai

    Shanghai L6: Sharp Member

    Messages:
    394
    Positive Ratings:
    217
    Chances are that Vtex uses the old Hammer file structure, from before the Steampipe update, so it's looking for resources which aren't there. I would suggest using VTFEdit instead.
     
    • Thanks Thanks x 1
  3. The Asylum

    aa The Asylum

    Messages:
    1,658
    Positive Ratings:
    439
    Yes, use VTFEdit. It's so much easier, and you can make any image size into one that conforms to hex standards (ie an image that's 600 x 500 -> 512 x 512)
     
  4. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    On the other hand, you might be able to use the vtex that is in the new SDK directory, rather than the old one.

    (that thing still has references to the VERC in it? sheesh, that was shut down years ago)
     
  5. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,629
    Positive Ratings:
    1,715
    I've had problems with mksheet.exe too. using the one in the hl2 directory seemed to work
     
  6. Verno

    Verno L2: Junior Member

    Messages:
    80
    Positive Ratings:
    32
    Okay I'll use that instead. What settings should I use or can I just stick with the defaults it gives?
     
  7. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    I recommend setting mipmap resizing method to "box" (basically a straight pixel resize that reduces every 2-by-2 square to one pixel) and mipmap sharpening to "none". VTEX actually has a default method that's a better compromise between no sharpening and the extreme options offered by VTFEdit, but for whatever reason it's not available as part of VTFEdit.

    Oh, and don't forget to do this to all your textures!
     
    • Thanks Thanks x 1