vrad issue after update

Discussion in 'Mapping Questions & Discussion' started by scotxland, Oct 21, 2011.

  1. scotxland

    scotxland L1: Registered

    Messages:
    1
    Positive Ratings:
    0
    This just started after the last update, when I compile my map, I get colored blotches on displacements. Each compile it's a random displacement and is red, blue, green or white.

    Example: http://i51.tinypic.com/15qw3g2.jpg

    Adjusting the lightmap scale seems to effect the color of the blotches. Any suggestions on what to look at next?
     
    Last edited: Oct 21, 2011
  2. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    569
    gotta bump that, i´m pretty frustrated about blotches on premuda which i´m trying to finish up.
    the blotches range from single-colored dots to rainbow-like constillations.

    is there a way to fix that issue?

    [​IMG][​IMG]
     
  3. Trotim

    aa Trotim

    Messages:
    1,179
    Positive Ratings:
    992
    afaik not. Started to happen to everyone some time ago, was definintely discussed before but I can't find where
     
  4. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,597
    Positive Ratings:
    1,677
    yes, the update that broke hammer right before halloween messed up vrad as well.
     
  5. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,902
    it's happening in valve maps too (so I guess you could get away with it). You could email people at valve and find out.
     
  6. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,557
    The funny colours issue is caused by a surface recieving small, insufficient amounts of light, having sufficient light sources usually prevents this issue. Though sometimes shadows are desirable in which case (if it doesn't negatively affect gameplay and thus warrant more light) you're kinda fucked.

    As for the light blotches, apparently that can be resolved by copy and pasting your map into a fresh file. Though if you're unlucky this often that just causes the lighting issue to move somewhere else in your map. I had this issue with a KoTH map i was making and the lighting bug seemed to remain at certain coordinates, moving the map around in hammer would cause the light to apply to different surfaces in the same pattern at the same coordinates. Odd.
     
    • Thanks Thanks x 2