VMF Corruption?

Discussion in 'Mapping Questions & Discussion' started by Darth Cyrax, Sep 5, 2012.

  1. Darth Cyrax

    Darth Cyrax L2: Junior Member

    Messages:
    94
    Positive Ratings:
    8
    Okay, this is the strangest bug I've ever come across, mainly due to its inconsistency:confused:. Anyways, here it goes.

    I believe Hammer is corrupting vmf files. This has happened to two distinct maps now, so I'm not sure what else to think.

    Here's what I've discovered so far:
    It causes world geometry to cease functioning. This is the main issue, as it does this seemingly at random each time I compile it. To get this out of the way, yes I AM SURE the geometry in question are not func_detail or any sort of brush entities. I do not have group ignore enabled. They do not have transparent textures on any face. They are not carved monstrosities or concave. The pointfile shows entities leaking through solid, 6 face rectangular geometry.

    I've tried cordoning the entire map to stop leaks to the void, which produced one compile log free of errors according to Interlopers(except for that skybox error on every TF2 map).
    I noticed in game that a few world geometry were missing, so I went back to hammer and replaced nodraw on world geometry with an opaque texture so I could easily identify the problem geometry in-game. Yet, the next compile log shows an areaportal leak, even though I made absolutely no other changes to the map. I loaded the pointfile, which shows an areaportal face leaking... TO THE EXACT SAME FACE:bored:.

    While I was in game on the error free compilation, there were some rather strange particle errors(the console showed that the particle table was full); when I fired the scattergun a bunch of red X's appeared instead of the regular bullets or muzzle flash. Strangely, most other particle effects(on the map and weapon based) worked.

    And perhaps the strangest part- If I copy the map exactly, piece by piece, into a fresh file, the errors stop for a few compiles, but eventually return. The compile logs before this error begins occurring show nothing strange in them- in fact, earlier I made a point of fixing the zero child area patch and node w/out a volume errors just in case they were the cause.

    I'm considering hiding areaportals and compiling so I can search for problem geometry in-game, but at this point I'm not sure that will solve anything if areaportal faces can leak to themselves :(.

    I've reinstalled Source SDK, as well as A Boojum Snark's Mapping Resource Pack, but it still persists.

    So, thanks for reading through this wall o' text, and let me know if you have any ideas.
     
  2. henke37

    aa henke37

    Messages:
    1,919
    Positive Ratings:
    449
    Is your computer stable?
     
  3. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    Have you remade the brushes shown as leaking? Sometimes they can be invalid or otherwise broken and it isn't apparent.
     
  4. Little Dude

    Little Dude L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    54
    An area portal leak can be caused by a number of things including moving brushes that it touches, or not enclosing the entire area where you have the area portal with other area portals or non-brush entity brushes. So if you were to have a window in a room with glass and the glass was a func_detail, you need to put an area portal in the hole where the window is located. Same for door ways, other entrances to the room, that sort of thing.
     
  5. Darth Cyrax

    Darth Cyrax L2: Junior Member

    Messages:
    94
    Positive Ratings:
    8
    Thanks for the responses guys.
    -My computer is stable, I haven't had any unexpected shutoffs or BSODs in a while. Hammer was crashing because of the ammopacks before I reinstalled the MRP, and still occasionally crashes when I Shift+Click+Drag Path_Tracks.

    -I have not remade the brushes yet, because they don't appear to be the some ones leaking each time. I will try that out with at least the ones I've confirmed to be leaking and get back to you.

    -The areaportal is sealed fully, as I said earlier it wasn't causing a leak before on one compile, and on the next one it was leaking even though I had not changed any geometry at all. It is, however, overlapping with a func_detail, so I could move that over so they're not colliding.
     
  6. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,035
    Positive Ratings:
    3,990
    How large is your map? I've seen similar happen on maps that were really enormous because VBSP or VVIS wasn't able to correctly build the map due to random errors. Either too many visleafs would want to load at once or it couldn't figure out the portals, that sort of thing.

    The only other thing I can suggest is that you do have a leak, despite what you think. Overlapping with a func_detail shouldn't matter.
     
  7. Mr. Happy

    Mr. Happy L6: Sharp Member

    Messages:
    320
    Positive Ratings:
    144
    You mentioned node without volume. You described non-sensical areaportal leak pointfiles. I've seen this type of stuff tons of times.

    It sounds to me like you have one of three issues:

    1. Complex leaf structure near area portals
    2. Area leaking to itself in multiple spots ways
    3. Areaportal, or brushes touching areaportal, with vertices slightly off grid

    I suspect if you delete a couple area portals, while trying to maintain a correct area portal structure, that either the error or the pointfile will change giving you new, more helpful information.

    I'm leaning towards three since you say recompiling without changes caused the error to appear.

    The overlapping func_detail *might* be a problem but I doubt it....really not sure on that one.
    --
    Another, less likely issue, may be that you have multiple areaportals on the same plane with world geometry between them. Coplanar areaportals get merged so I can see how that might cause an issue (as the new, merged, areaportal would cross world geometry).
     
  8. Darth Cyrax

    Darth Cyrax L2: Junior Member

    Messages:
    94
    Positive Ratings:
    8
    Very strange. I decided to ignore this problem for a bit in favor of doing some actual work on the map, and now the compile log is error free. There's still some weird stuff going on with the particles, but according to google/steam forums that's a completely unrelated problem.

    yyler- My map isn't very large(not as big as, say, badwater)

    Mr. Happy- As I mentioned, one of the first things I did when this happened was to track down those brushes causing the node w/o a volume and zero area child patch and replace them(they were some relatively complex/rotated func_details).

    There were no really strange leaf structures near the areaportal. Loading the portalfile showed noting out of the ordinary, and in general I tend to func_detail anything that isn't rectangular or essential to sealing the map. There were some func_details with transparent textures that were coplanar and overlapping the areaportal in question, so I moved those a bit just in case.

    On the instance I mentioned where an areaportal face leaked to itself, I did check and the area was totally sealed(the fact that it disappeared the next compile seems to corroborate this).
    And in all honesty, the point file really did show the red line traveling away from the areaportal face, doing a u-turn, and leading back to the exact same face ಠ_ಠ .

    Also, I always align areaportals to the grid, and never rotate them in increments less than 90 degrees (to prevent funky visleafs).

    There aren't any areaportals coplanar with the one in question.

    Thanks for the responses guys, I'll keep updating this if something new pops up.
     
    Last edited: Sep 7, 2012