VGUI memory issues/performance?

Discussion in 'Mapping Questions & Discussion' started by Rexy, May 25, 2009.

  1. Rexy

    aa Rexy The Kwisatz Haderach

    Messages:
    1,795
    Positive Ratings:
    2,366
    I have something I can't figure out--the only thing I can think of is there's some memory leak going on, but I can't figure out what's causing it.

    First of all, I want to say the map has no leaks and compiles without issues. The problem happens approximately 30-60 seconds after loading the map.

    The map will run great, my FPS will be fine, sometimes 90+ for the start of the map, but after a time, the fps drops down below 30, continuing until I'm at single digit FPS...

    I used showbudget to examine what's causing this, and VGUI/VGUI2 starts off at a normal level, then skyrockets after about 30 seconds, climbing slowly until it's off the charts. Then the fps continues to drop even lower.

    Here's some images of that:

    [​IMG]
    [​IMG]
    [​IMG]

    What's going on? What's causing VGUI to freak out like that? I've got the map fully optimized, I can tell it's running great when the map first loads...but it's like there's a memory leak and the FPS drops into the toilet. Any help would be great.

    Thanks.
     
  2. The Political Gamer

    aa The Political Gamer

    Messages:
    4,468
    Positive Ratings:
    1,682
    Could you post the .vmt or .bsp? That would really help.
     
  3. Rexy

    aa Rexy The Kwisatz Haderach

    Messages:
    1,795
    Positive Ratings:
    2,366
    How so?
     
  4. l3eeron

    l3eeron L8: Fancy Shmancy Member

    Messages:
    594
    Positive Ratings:
    85
    This is just a hunch.

    ...I don't see any kind of game mode in the HUD. Is that a Cp, ctf or payload map? Set up the game entities completely, as they control the HUD. If the HUD is all hosed then it would show under vgui in the showbudget (I think!)
     
    • Thanks Thanks x 1
  5. Rexy

    aa Rexy The Kwisatz Haderach

    Messages:
    1,795
    Positive Ratings:
    2,366
    I'll give that a try, thanks!
     
  6. Rexy

    aa Rexy The Kwisatz Haderach

    Messages:
    1,795
    Positive Ratings:
    2,366
    It worked. I wasn't going to set up the rest of the game entities until I had finished layout, but the VGUI seems to go stupid when you don't have it all together. Thanks for your hunch!
     
  7. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    For the record, the budget panel is a vgui panel, so that bar will always spike when you are viewing the budget since it's such a complex display with tons of crap going on.
     
  8. Rexy

    aa Rexy The Kwisatz Haderach

    Messages:
    1,795
    Positive Ratings:
    2,366
    I knew that--but the amount of resource it was consuming could not even begin to account for the small spike normally viewed with showbudget. Good thing for l3eeron's hunch.
     
  9. l3eeron

    l3eeron L8: Fancy Shmancy Member

    Messages:
    594
    Positive Ratings:
    85
    Well, glad I can help. :)
     
  10. Ezekel

    Ezekel L11: Posh Member

    Messages:
    818
    Positive Ratings:
    244
    an interesting thing i've noticed in general.
    on payload maps, if you load the map, but no one joins a team, the VGUI steadily climbs over time.
    as soon as someone joins a team though, everything is fine, and the VGUI falls dramatically. - when i spec on payload maps i usually join a team and then go spec after choosing a class to avoid this slow down effect
     
  11. Loc_n_lol

    Loc_n_lol L10: Glamorous Member

    Messages:
    726
    Positive Ratings:
    273
    I've ha this happen to me recently too, quite annoying.
    However, here he is playing as a scout.