vbsp.exe has stoped working (compile error) HELP!

Discussion in 'Mapping Questions & Discussion' started by Sheltr, Feb 24, 2011.

  1. Sheltr

    Sheltr L3: Member

    Messages:
    107
    Positive Ratings:
    61
    I'm not sure what went wrong, I just keep trying to compile my map but this error comes up every time.


    ** Executing...
    ** Command: "c:\program files\steam\steamapps\thecrazytoaster\sourcesdk\bin\orangebox\bin\vbsp.exe"
    ** Parameters: -game "c:\program files\steam\steamapps\thecrazytoaster\team fortress 2\tf" "C:\Program Files\Steam\steamapps\thecrazytoaster\sourcesdk_content\tf\mapsrc\sdk_cp_Redstone_Alpha.vmf"

    Valve Software - vbsp.exe (Jul 7 2010)
    2 threads
    materialPath: c:\program files\steam\steamapps\thecrazytoaster\team fortress 2\tf\materials
    Loading C:\Program Files\Steam\steamapps\thecrazytoaster\sourcesdk_content\tf\mapsrc\sdk_cp_Redstone_Alpha.vmf
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    Patching WVT material: maps/sdk_cp_redstone_alpha/dev/dev_blendmeasure2_wvt_patch
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    **** leaked ****
    Entity prop_static (-1314.00 -3277.00 -58.00) leaked!
    Processing areas...done (0)
    Building Faces...done (0)
    Chop Details...done (0)
    Find Visible Detail Sides...done (0)
    Merging details...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    done (1)
    Creating default LDR cubemaps for env_cubemap using skybox materials:
    skybox/sky_day01_01*.vmt
    ! Run buildcubemaps in the engine to get the correct cube maps.
    Creating default HDR cubemaps for env_cubemap using skybox materials:
    skybox/sky_day01_01*.vmt
    ! Run buildcubemaps in the engine to get the correct cube maps.
    Finding displacement neighbors...
    Found a displacement edge abutting multiple other edges.
    Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...

    ** Executing...
    ** Command: "c:\program files\steam\steamapps\thecrazytoaster\sourcesdk\bin\orangebox\bin\vvis.exe"
    ** Parameters: -game "c:\program files\steam\steamapps\thecrazytoaster\team fortress 2\tf" "C:\Program Files\Steam\steamapps\thecrazytoaster\sourcesdk_content\tf\mapsrc\sdk_cp_Redstone_Alpha"

    Valve Software - vvis.exe (Jul 7 2010)
    2 threads
    reading c:\program files\steam\steamapps\thecrazytoaster\sourcesdk_content\tf\mapsrc\sdk_cp_Redstone_Alpha.bsp
    Error opening c:\program files\steam\steamapps\thecrazytoaster\sourcesdk_content\tf\mapsrc\sdk_cp_Redstone_Alpha.bsp

    ** Executing...
    ** Command: "c:\program files\steam\steamapps\thecrazytoaster\sourcesdk\bin\orangebox\bin\vrad.exe"
    ** Parameters: -game "c:\program files\steam\steamapps\thecrazytoaster\team fortress 2\tf" "C:\Program Files\Steam\steamapps\thecrazytoaster\sourcesdk_content\tf\mapsrc\sdk_cp_Redstone_Alpha"

    Valve Software - vrad.exe SSE (Jul 7 2010)

    Valve Radiosity Simulator
    2 threads
    [Reading texlights from 'lights.rad']
    [34 texlights parsed from 'lights.rad']

    Loading c:\program files\steam\steamapps\thecrazytoaster\sourcesdk_content\tf\mapsrc\sdk_cp_Redstone_Alpha.bsp
    Error opening c:\program files\steam\steamapps\thecrazytoaster\sourcesdk_content\tf\mapsrc\sdk_cp_Redstone_Alpha.bsp

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files\Steam\steamapps\thecrazytoaster\sourcesdk_content\tf\mapsrc\sdk_cp_Redstone_Alpha.bsp" "c:\program files\steam\steamapps\thecrazytoaster\team fortress 2\tf\maps\sdk_cp_Redstone_Alpha.bsp"

    The command failed. Windows reported the error:
    "The system cannot find the file specified."

    If you can help that would be great.
     
  2. Wander

    Wander L3: Member

    Messages:
    148
    Positive Ratings:
    42
  3. Sheltr

    Sheltr L3: Member

    Messages:
    107
    Positive Ratings:
    61
    Ive looked around the map, I thought it was some props leaking out of the skybox. I fixed it but then tried Recompiling the map. same thing not sure whats wrong with my displacements tho. I looked on the site the info was not much help. Not sure whats wrong.
     
  4. Sheltr

    Sheltr L3: Member

    Messages:
    107
    Positive Ratings:
    61
    Ive fixed the gap in the map it was the props. I need help with the displacements tho. not sure what to do can some one help?
     
  5. Vincent

    aa Vincent 🔨 Grandmaster Lizard Wizard Jedi 🔨

    Messages:
    914
    Positive Ratings:
    580
    Destroy them and remake them, try not to get to crazy with how you manipulate the displacements next time.
     
  6. Sheltr

    Sheltr L3: Member

    Messages:
    107
    Positive Ratings:
    61
    So There is no way around this? I have to remove them all? I don't see what i got so crazy with. there just normal displacements. so it makes the ground not so... flat, theres no big ass hills, or random walls. just normal displacements. is there some why I can fix this without having to remove them all?
     
  7. ardysqrrl

    ardysqrrl L4: Comfortable Member

    Messages:
    173
    Positive Ratings:
    159
    this is usually an ignorable error, is vbsp still crashing?

    you can fix it without removing them all by narrowing down the problem using the cordon tool
     
    • Thanks Thanks x 1
  8. Sheltr

    Sheltr L3: Member

    Messages:
    107
    Positive Ratings:
    61
    Yeah vbsp is still crashing and how do I fix them, you said I can but not how?
     
  9. Duke Silas

    Duke Silas L1: Registered

    Messages:
    40
    Positive Ratings:
    18
    Have you sealed your displacements with nodraw brushes?
    Using the cordon tool wil help you check your map for compile errors section by section. Click on the link from ardysqrrl and it will explain how to use the tool.
     
  10. ardysqrrl

    ardysqrrl L4: Comfortable Member

    Messages:
    173
    Positive Ratings:
    159
    to clarify, you should cordon off part of your map, try to compile, cordon off another part and try to compile, and repeat until you've narrowed down the problem using this method.
     
  11. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    Also, is vbsp crashing or 'hanging'? If you are using lighting it can take a LONG time to light, and it seems like it's crashing because it takes almost all cpu power and doesn't show you anything is working.

    You can bring up the task manager and look for Hammer. If it says cpu 98% or something it is still working.

    Your log up there said leaked. Do you still get that? It will only show one leak at a time. So fix that, compile, look for another possible leak (map>load pointfile)

    I believe that displacement error is because you have 2 displacements next to each other (ground), but also the side of one of those brushes is a displacement (below ground 'wall'). You need to find that brush ONLY. destroy it, select only the top face, create displacement.
     
  12. Sheltr

    Sheltr L3: Member

    Messages:
    107
    Positive Ratings:
    61
    Thanks for all the help guys, Ive found the problem its the displacements under the "point/capture zone"
    Trying not to give out much about my map tell its finished, or attest playable. I'm guessing the displacement can't touch another displacement or 2 displacements on the same side. if this is the problem then I will just have to split it in half right? so its not touching the same side or whatever. Once again thanks for all you're help, I plan on keep fixing this map tell I get it right! But for all the help you've given me Ill attest give you the name of the map if you already don't know from the compile list Ive shown. heh well the map's name isssss! Koth_redstone. I hope this name is not already taken. :p
     
  13. ardysqrrl

    ardysqrrl L4: Comfortable Member

    Messages:
    173
    Positive Ratings:
    159
    It's possible to have 2 displacements sewn to the same side of another displacement, given that the edges on the smaller displacements are each exactly half the width of the larger one

    there was probably something else wrong with how the displacements were set up, but I'm glad you got it fixed!
     
    Last edited: Feb 25, 2011
  14. Sheltr

    Sheltr L3: Member

    Messages:
    107
    Positive Ratings:
    61
    Well I didn't fix it yet. I just know what part is wrong. but I'm sure I can figure this out on my own