Underwater look issues

Discussion in 'Mapping Questions & Discussion' started by Motanum, Nov 9, 2011.

  1. Motanum

    Motanum L2: Junior Member

    Messages:
    53
    Positive Ratings:
    13
    Hello,

    I have a little blue spawn that is under water and they exit through a hole on the floor. So this involve some water brushes.

    I made them all square, with nodraw expet for the top and without clipping through each other. It looks like this

    http://steamcommunity.com/id/Motanum/screenshot/595827796526830882?tab=public and if I move around maybe liek this http://steamcommunity.com/id/Motanum/screenshot/595827796526844361

    How can I fix this?

    I also have a water analog (Moving water) on the other side of a tunnel. However, the water analog is up by the time blue is able to spawn in the little underwater locker spawn.

    Thanks!
     
  2. Crash

    aa Crash func_nerd

    Messages:
    3,132
    Positive Ratings:
    4,712
    Water analog's don't get water shaders inside of them. I ran into this same problem before. You have to put them in places that isn't going to be swam in. Kind of lame.

    I suppose if you did it right you might be able to get away with throwing in fog or something set up to triggers for that area, but I wouldn't know how to do that personally.
     
  3. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    Make a secondary fog controller and a trigger in the water to activate that fog. It's handled client side so 1 player wont trigger it for everyone. A similar thing is done in 2fort to change fog settings around the base.

    But i wouldn't recommend doing this to simmulate water. Just use a proper water texture with the appropriate shaders.
     
  4. Motanum

    Motanum L2: Junior Member

    Messages:
    53
    Positive Ratings:
    13
    Wait, what about the issue that visibility clips? that is my biggest problem, not that it stops looking like water for a second...
     
  5. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    Looking at the pics it would appear you have a leak. A leak is a hole in your map that leaks to the void, the first entity to leak is not the problem but simply the closest entity to the hole. Load yout pointfile to get a red line that directs you to the hole, from the leaked entity, so you can seal it.
     
  6. Motanum

    Motanum L2: Junior Member

    Messages:
    53
    Positive Ratings:
    13
    There are no leaks. I am getting rid of the analog, see if that fixes it