Two quick questions.

Discussion in 'Mapping Questions & Discussion' started by NameUser, Oct 6, 2011.

  1. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    In my map, at theedges there are upwards slopes at a 90 degree angle done with the clipping tool. However, for some reason they have some odd lighting issues. Various peices of them will appear darker than the rest, or even pure black. Does anyone know the cause of this?
    My second questions is a matter of how to do something optimally. I want to remove the slopes and just replace them with a plain stretching into the distance, scattered with a few trees. My question is, how could I do this? The obvious solution would be to just have a peice of ground stretching off out of the skybox, but I'm pretty sure that is a major optimization 'no, no'. So what would be the best way to go about this?
     
    Last edited: Oct 6, 2011
  2. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,105
    Positive Ratings:
    6,003
    Second question: use a 3D skybox. These allow the game to render a small, optimisable area at a massive scale.

    First question: Well, firstly, never use the Carve tool. I'ts a pain, because it often makes very poorly optimised shapes. Secondly, the only advice i can give you there is to remake the brushes. That isn't a new problem though, so with a bit of luck someone else can help.
     
    • Thanks Thanks x 1
  3. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    My mistake. I used the clipping tool, not the carve tool.
     
  4. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    Clipping tool can also cause this issue, again, try remaking brushes.
     
    • Thanks Thanks x 1
  5. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    I've got another question, but I already have a thread, so no reason to make a new one. ;)

    Is there any way to get a weapon's model to work properly as a prop? When I set a prop_static to have a weapon's model, it doesn't show in game.
     
  6. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    You have to set it as a prop_dynamic.
     
    • Thanks Thanks x 1
  7. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    Ah. Sorry if I seem kind of new, because... well I am. This is my first map. :p
     
  8. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,032
    Positive Ratings:
    3,978
    For the future: when you are viewing a prop in the model browser, look at the Info tab. The boxes checked indicate what kind of prop you can use the model as. Usually static is available and you should use that, but sometimes things need to be dynamic (lantern002.mdl for example).
     
    • Thanks Thanks x 1
    Last edited by a moderator: Oct 6, 2011
  9. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    One more question, this one being more of a curiousity. Those balls that are often seen in trade maps. How are they done? I mean, I can find the prop for it of course, but how do I apply the physics to it?
     
  10. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    props_physics_multiplayer?

    I believe that is it. They are a little buggy though when they collide with people
     
    • Thanks Thanks x 1
  11. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    I hate to keep asking questions, and I feel like you must think I'm not trying to figure out things on my own (I am. IF I wasn't I would have asked ALOT more questions :p). For one, the balls has physics applied now, but it has a minor issue. It's solid while it's not moving, and non-solid after you've hit it. How can I make it solid after being hit, or non-solid before being hit?
    Also, my water is very messed up and is showing the skybox rather than the water or a reflection. I beleive this is because I screwed up building the cubemaps, however if I try to build them again Team Fortress 2 instantly crashes. I assume this is because it has already built the cubemaps. Is there any way to remove th cubemaps?
     
  12. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    Not sure about the ball,

    But the water is because you have a leak (a hole into the void). You need to seal your map up for the water to work. i.e: compile the map, and then load the pointfile, it will have a red line appear along the path where the leak is, find it, seal it. compile the map again, load the pointfile again, seal any leaks again.

    Repeat until no red line pops up (you'll get a window asking if you want to load a file)...

    Or you could be in full bright, which to fix this, you just add some lights.
     
  13. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    No full bright, so it must be a leak. Odd, I didn't notice any leak errors when I compile. Anyways, thanks. I'll fix that.
     
  14. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    I also forgot to mention an invalid solid will cause this too (So, carved, sometimes hollowed brushes, and sometimes vertex editing can cause this.