two questions...

Discussion in 'Mapping Questions & Discussion' started by cornontheCoD, Mar 26, 2008.

  1. cornontheCoD

    cornontheCoD L7: Fancy Member

    Messages:
    437
    Positive Ratings:
    70
    1. When I type in "tf" in my keywords section for textures, hammer freezes. everytime i do it, it freezes. how do i get it to work?

    2. How do i test my map? with portal, you could just go to the console and type in "map mapname" and it would work. I tried it with TF2, and it doesnt work. do I need to move the map into the maps folder?
     
  2. Spike

    Spike L10: Glamorous Member

    Messages:
    716
    Positive Ratings:
    82
    To test the map just create a server and choose the map
     
  3. DJive

    aa DJive Cake or Death?

    Messages:
    1,466
    Positive Ratings:
    736
    1: Sometimes it will depending on your system specs. Heres what you can do though.

    Click "Only Used Textures" then type "tf" in the Keywords. Nothing should show *unless you already have tf2 textures*

    Now type what your looking for in the filter IE: "Concrete" "floor" "wall" ETC. and now UNCLICK the "Only Used Textures"

    Easy work around, and this way also saves system load on unused textures.

    2. Your TF2 maps will need to be saved in this folder.
    C:\Program Files\Steam\SteamApps\t3ch82\team fortress 2\tf\maps

    After that as you said though, bring down console and type "map mapname"
     
  4. Ze Inspector

    Ze Inspector L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    I've had this problem before too. I usually try and trick hammer and give it a filter then giving it the tf keyword and then it usually works without issue the rest of the time I'm using it.

    Very similar to DJive's suggestion, just a different approach.
     
  5. l3eeron

    l3eeron L8: Fancy Shmancy Member

    Messages:
    594
    Positive Ratings:
    85

    :lol:

    I do the same thing, omg thats hilarious. Its like it has to reload the cache for all the textures every once n a while... so I always go to "only used textures" first then put TF, then uncheck only used....


    Otherwise... it takes like 10 minutes to finish reloading the "stuff"
     
  6. Half-Life_Maniac

    Half-Life_Maniac L3: Member

    Messages:
    122
    Positive Ratings:
    88
    Same here- it's absolutely ridiculous. Even on my brand new computer, I can wait up to 2 minutes. With my old computer, simply scrolling through the list of textures was a nightmare.

    One thing you can do is try and remove as many textures from the list as possible. By default, anything that slightly resembles an image file will be shown in the browser: model textures, sprites, HUD icons, Hammer sprites, skyboxes, splash backgrounds, particle sprites, the lot.

    If you go in Tools-Options-Materials, you can use the "Material directory exclusion list" to get rid of some fo those useless textures and prevent them clogging up the texture browser.
    You'll have to have all your materials extracted somewhere , and then just use the "Add.." button to add those folders. Most of the junk listed above can be added (from TF2 and HL2) except I think you'll need model textures and Hammer sprites left alone, or else you'll get problems.
     
  7. TheBladeRoden

    TheBladeRoden L7: Fancy Member

    Messages:
    491
    Positive Ratings:
    165
    yeah, RAM is your friend when texture browsing
     
  8. TotalMark

    TotalMark L6: Sharp Member

    Messages:
    331
    Positive Ratings:
    40
    I'll betcha I have the worst computer here, and it doesn't freeze as bad as you guys are making it sound. At least not for me anyway.
     
  9. phatal

    phatal L6: Sharp Member

    Messages:
    259
    Positive Ratings:
    21
    I guess I'm a lucky fella. 4gigs and a quad 3.6ghz does this almost immediately. :p
     
  10. Spike

    Spike L10: Glamorous Member

    Messages:
    716
    Positive Ratings:
    82
    Can you tell me how did you get that frequency? By air or liquid cooler? How much did your cooler cost and how many coolers do you have, 1 on the processor and a general one?

    I've got an intel Quad too and I want to OC it, but It would be the first time :S