1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

Trouble getting a spotlight to work.

Discussion in 'Mapping Questions & Discussion' started by drp, Nov 12, 2007.

  1. drp

    aa drp

    Messages:
    2,256
    Positive Ratings:
    2,572
    :thumbdown:

    This might sound noobish but I tried for 2 hours last night trying to get a spotlight to work, but failed. I even tried looking in to the valve maps but nothing. Copied over their light entities and still didn't work. Anyone want to shine some light on this? (pun intended)
     
  2. spaceweasels

    aa spaceweasels

    Messages:
    219
    Positive Ratings:
    336
    Is it not working at all? or is it not pointing where you wanted it to point?

    If it's not working at all, I would go leak hunting. If you've got a leak in your map, the light entities won't work properly.

    If it isn't pointing where you want it to point, create an info_target entity. in the light_spot entity properties, you'll see a field called entity to point at. Just enter the name of the info_target entity.
     
  3. drp

    aa drp

    Messages:
    2,256
    Positive Ratings:
    2,572
    no, its not working at all. ive checked for leaks and have none. i made a large brush and just hollowed it out and made the skybox like that for testing, so no leaks are possible.

    regular lights work, but light spots dont.
     
  4. MrTwitch

    MrTwitch Guest

    Positive Ratings:
    0
    The most fun is when you get lazy and make detailed styrofoam cups in Hammer instead of using a modeling program and wonder why, when you run your map that none of your entities are appearing...
     
  5. Logo

    Logo L3: Member

    Messages:
    115
    Positive Ratings:
    26
    So it's a light_spot entity and it's not shining? Be sure that the entity is not inside a prop entity (my general guide is that the yellow line that appears in the light entity when viewing it in the 2d views should not be inside of anything else). Also try upping the brightness especially if you are using a skybox texture and/or light_environment as it could be overpowering the light.

    Also play with the inner (bright) and outer angles of the light.

    Screenshots would be helpful in debugging the issue.
     
  6. spaceweasels

    aa spaceweasels

    Messages:
    219
    Positive Ratings:
    336
    If you can, also post up the VMF file. That way we can take a thorough look.
     
  7. drp

    aa drp

    Messages:
    2,256
    Positive Ratings:
    2,572
    thanks guys, ill post screenshots along with the vmf sample when i get home.