Triggers Showing In Game, Need Help with Leak

Discussion in 'Mapping Questions & Discussion' started by DisruptedHunter, Dec 22, 2014.

  1. DisruptedHunter

    DisruptedHunter L2: Junior Member

    Messages:
    89
    Positive Ratings:
    1
    ** Executing...
    ** Command: "F:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "F:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Backup Folders\Documents\Tf2 maps\Mapping\xmas\idle_cy4g_winterdreams.vmf"

    Valve Software - vbsp.exe (Dec 7 2014)
    8 threads
    materialPath: F:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Backup Folders\Documents\Tf2 maps\Mapping\xmas\idle_cy4g_winterdreams.vmf
    "materials/mytextures/custom_blackfukufsfkjsd.vtf": cached version doesn't exist
    material "nature/ice001" not found.
    Material not found!: NATURE/ICE001
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    Can't find surfaceprop WoodWood_Lowdensity for material MYTEXTURES/CUSTOM_WINTERPATTERN2, using default
    Patching WVT material: maps/idle_cy4g_winterdreams/brick/blendcobbletocobblesnow001_wvt_patch
    Patching WVT material: maps/idle_cy4g_winterdreams/pl_barnblitz/blendsnowtodirt001_wvt_patch
    Patching WVT material: maps/idle_cy4g_winterdreams/nature/blendgroundtograss001b_wvt_patch
    Patching WVT material: maps/idle_cy4g_winterdreams/maritime/nature/maritime_grass002_wvt_patch
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
    Processing areas...done (0)
    Building Faces...error: material NATURE/SNOWWALL002A doesn't have a $bottommaterial
    error: material NATURE/SNOWWALL002A doesn't have a $bottommaterial
    done (0)
    Chop Details...done (0)
    Find Visible Detail Sides...
    Merged 1414 detail faces...done (0)
    Merging details...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    done (1)
    writing C:\Backup Folders\Documents\Tf2 maps\Mapping\xmas\idle_cy4g_winterdreams.prt...Building visibility clusters...
    done (0)
    *** Error: Skybox vtf files for skybox/sky_halloween weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_halloween to build the default cubemap!
    *** Error: Skybox vtf files for skybox/sky_halloween weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_halloween to build the default cubemap!
    Finding displacement neighbors...
    Found a displacement edge abutting multiple other edges.
    Warning: overflowed 20 displacement corner-neighbor lists.Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...
    done (1) (1066861 bytes)
    Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
    Water found with no water_lod_control entity, creating a default one.
    Compacting texture/material tables...
    Reduced 6323 texinfos to 3730
    Reduced 144 texdatas to 116 (4285 bytes to 3099)
    Writing C:\Backup Folders\Documents\Tf2 maps\Mapping\xmas\idle_cy4g_winterdreams.bsp
    4 seconds elapsed

    ** Executing...
    ** Command: "F:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "F:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -fast "C:\Backup Folders\Documents\Tf2 maps\Mapping\xmas\idle_cy4g_winterdreams"

    Valve Software - vvis.exe (Dec 7 2014)
    fastvis = true
    8 threads
    reading c:\backup folders\documents\tf2 maps\mapping\xmas\idle_cy4g_winterdreams.bsp
    reading c:\backup folders\documents\tf2 maps\mapping\xmas\idle_cy4g_winterdreams.prt
    4977 portalclusters
    18129 numportals
    BasePortalVis: 0...1...2...3...4...5...6...7...8...9...10 (5)
    Optimized: 1868336 visible clusters (16.59%)
    Total clusters visible: 11260955
    Average clusters visible: 2262
    Building PAS...
    Average clusters audible: 3608
    visdatasize:4477890 compressed from 6211296
    writing c:\backup folders\documents\tf2 maps\mapping\xmas\idle_cy4g_winterdreams.bsp
    7 seconds elapsed

    ** Executing...
    ** Command: "F:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "F:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Backup Folders\Documents\Tf2 maps\Mapping\xmas\idle_cy4g_winterdreams"

    Valve Software - vrad.exe SSE (Dec 7 2014)

    Valve Radiosity Simulator
    8 threads
    [Reading texlights from 'lights.rad']
    [37 texlights parsed from 'lights.rad']

    Loading c:\backup folders\documents\tf2 maps\mapping\xmas\idle_cy4g_winterdreams.bsp
    Setting up ray-trace acceleration structure... Done (2.21 seconds)
    18780 faces
    24 degenerate faces
    5524470 square feet [795523648.00 square inches]
    814 Displacements
    2731135 Square Feet [393283424.00 Square Inches]
    18756 patches before subdivision
    224310 patches after subdivision
    0 direct lights
    BuildFacelights: 0...1...2...3...4...5...6...7...8...9...10 (1)
    BuildVisLeafs: 0...1...2...3...4...5...6...7...8...9...10 (32)
    transfers 27960771, max 2180
    transfer lists: 213.3 megs
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #1 added RGB(0, 0, 0)
    Build Patch/Sample Hash Table(s).....Done<0.1030 sec>
    FinalLightFace: 0...1...2...3...4...5...6...7...8...9...10 (12)
    FinalLightFace Done
    0 of 0 (0% of) surface lights went in leaf ambient cubes.
    ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (10)
    Writing leaf ambient...done
    Ready to Finish

    Object names Objects/Maxobjs Memory / Maxmem Fullness
    ------------ --------------- --------------- --------
    models 73/1024 3504/49152 ( 7.1%)
    brushes 3163/8192 37956/98304 (38.6%)
    brushsides 32812/65536 262496/524288 (50.1%)
    planes 39522/65536 790440/1310720 (60.3%)
    vertexes 31556/65536 378672/786432 (48.2%)
    nodes 9098/65536 291136/2097152 (13.9%)
    texinfos 3730/12288 268560/884736 (30.4%)
    texdata 116/2048 3712/65536 ( 5.7%)
    dispinfos 814/0 143264/0 ( 0.0%)
    disp_verts 37542/0 750840/0 ( 0.0%)
    disp_tris 55520/0 111040/0 ( 0.0%)
    disp_lmsamples 4037104/0 4037104/0 ( 0.0%)
    faces 18780/65536 1051680/3670016 (28.7%)
    hdr faces 0/65536 0/3670016 ( 0.0%)
    origfaces 11995/65536 671720/3670016 (18.3%)
    leaves 9172/65536 293504/2097152 (14.0%)
    leaffaces 22363/65536 44726/131072 (34.1%)
    leafbrushes 6791/65536 13582/131072 (10.4%)
    areas 6/256 48/2048 ( 2.3%)
    surfedges 141451/512000 565804/2048000 (27.6%)
    edges 81486/256000 325944/1024000 (31.8%)
    LDR worldlights 0/8192 0/720896 ( 0.0%)
    HDR worldlights 0/8192 0/720896 ( 0.0%)
    leafwaterdata 6/32768 72/393216 ( 0.0%)
    waterstrips 2516/32768 25160/327680 ( 7.7%)
    waterverts 0/65536 0/786432 ( 0.0%)
    waterindices 42942/65536 85884/131072 (65.5%)
    cubemapsamples 0/1024 0/16384 ( 0.0%)
    overlays 0/512 0/180224 ( 0.0%)
    LDR lightdata [variable] 7697716/0 ( 0.0%)
    HDR lightdata [variable] 0/0 ( 0.0%)
    visdata [variable] 4477890/16777216 (26.7%)
    entdata [variable] 22361/393216 ( 5.7%)
    LDR ambient table 9172/65536 36688/262144 (14.0%)
    HDR ambient table 9172/65536 36688/262144 (14.0%)
    LDR leaf ambient 5847/65536 163716/1835008 ( 8.9%)
    HDR leaf ambient 9172/65536 256816/1835008 (14.0%)
    occluders 0/0 0/0 ( 0.0%)
    occluder polygons 0/0 0/0 ( 0.0%)
    occluder vert ind 0/0 0/0 ( 0.0%)
    detail props [variable] 1/12 ( 8.3%)
    static props [variable] 1/12 ( 8.3%)
    pakfile [variable] 4987/0 ( 0.0%)
    physics [variable] 1066861/4194304 (25.4%)
    physics terrain [variable] 156670/1048576 (14.9%)

    Level flags = 0

    Total triangle count: 55554
    Writing c:\backup folders\documents\tf2 maps\mapping\xmas\idle_cy4g_winterdreams.bsp
    57 seconds elapsed

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Backup Folders\Documents\Tf2 maps\Mapping\xmas\idle_cy4g_winterdreams.bsp" "F:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\idle_cy4g_winterdreams.bsp"



    This is with all point entity's off. I also have a displacement error as you can see in the log, but I've done it with props off, AND displacements off and I still get this. When I go to load pointfile nothing happens. I don't know where the leak is I can't find any errors. I turn off lights, I turn off props, displacements, I still get weird errors. Can someone help me really fast? I already have a the previous version of this map up on my server. All I did was fix a few things like displacements not being closed and add some lights near props so they looked lit up. Everything was fine then I added 2 more light and a sparkle effect here and there and then it stopped working.

    Here's what it looks like.


    [​IMG]


    Any help? Id like to fix this today so I can upload the new version.
     
  2. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,387
    Positive Ratings:
    4,219
    What is this? A .png for ants?!

    You seem to have an error relating to displacements. (Warning: overflowed 20 displacement corner-neighbor lists.) I'm not sure what it means, but running the compile log through Interlopers should yield some answers.

    Also, disabling all of your entities will create a leak 'cos the compiler uses entities to figure out which bit of the map is the map itself and which bit is the void.

    As for the trigger brushes, I don't know what to say. The only times I've seen them render in-game was when I forgot to turn them into brush entities, so they were just regular old (solid) brushes. Maybe you've done the same?
     
    • Thanks Thanks x 1
    Last edited: Dec 22, 2014
  3. DisruptedHunter

    DisruptedHunter L2: Junior Member

    Messages:
    89
    Positive Ratings:
    1

    I stated in my OP that I already turned off displacements to check if it was. I've tried turning that off and props, I've tried deleting stuff, I even am getting errors when props are all on now because of wherever the issue is. If I turn off props? Still get it. If I turn off displacements? Still get it. Both? Still get it. point entitys ? still get it. I also ungrouped some...oh.


    OH! Looks like It's my fault. I ungrouped some triggers by sending them to world and thats what caused all these problems. I'm such a goof. I was watching tv while doing stuff I guess that's what the issue is. Sorry to make a waste of a post . Happy holidays!