trigger_catapult does not catapult me to the target

Discussion in 'Mapping Questions & Discussion' started by Asd417, Jul 2, 2016.

  1. Asd417

    aa Asd417 L1: Registered

    Messages:
    698
    Positive Ratings:
    482
    so I'm making the jumppad for passtime but the jump pad sends me to the right of the target. I copied the jump pad from pass_template.vmf but the problem seems to be there too. (the red jump pad) but the blue one doesn't. anyone know why?
     
  2. henke37

    aa henke37

    Messages:
    1,837
    Positive Ratings:
    420
    We have no idea what you did. We can't troubleshoot without information. Show us the entities. Or just the entire uncompiled map, that works too.
     
  3. Asd417

    aa Asd417 L1: Registered

    Messages:
    698
    Positive Ratings:
    482
  4. Egan

    aa Egan

    Messages:
    1,302
    Positive Ratings:
    1,478
    The trigger_push you have above the trigger_catapult is in the wrong direction. You can set the direction with the 'Push Direction' keyvalue. It looks like you tried moving the origin of the brush to a direction instead.

    [​IMG]


    Can see here that 0 0 0 faces sideways, which is why your catapult is pushing you slightly sideways:

    [​IMG]

    If you use rotate this teamspawn guy towards the direction you want, you can then copy its Pitch Yaw Roll into the move direction of the trigger_push:

    [​IMG]
     
  5. Asd417

    aa Asd417 L1: Registered

    Messages:
    698
    Positive Ratings:
    482
    so the trigger_push was the problem! Thanks