Train SFX don't stop when they should

Discussion in 'Mapping Questions & Discussion' started by PL-7764, Jan 7, 2011.

  1. PL-7764

    PL-7764 L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    67
    I've just followed Spammish's train tutorial and made a working train (and, with some entity experimentation, added working gates :thumbup:), but there's a problem: when the train reaches the path_track which contains the OnPass output to stop the train sound, it doesn't stop. It seems that I can't even make it stop in-game using the ent_fire console command. :\

    I've double-checked all my entities, and it's clear that the ambient_generic producing the sound is hooked up to receive the StopSound command from the path_track, but for some reason it still doesn't.

    What should I do to make it stop?

    I can upload my .VMF if needed, but it's virtually identical to the one built by Spammish in the linked thread, except for the addition of gates, which I know had nothing to do with the problem as it was there before the gates were added.
     
    Last edited: Jan 7, 2011
  2. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    Once an ambient_generic starts playing sound, it can't stop IIRC. Set its volume to 0 instead.
     
    • Thanks Thanks x 1
  3. PL-7764

    PL-7764 L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    67
    That works. Thanks!
     
  4. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    If I remember, there was a flag that was "repeat" and is on by default, if you turn that off, it should only play when going by.

    But if Seba's way worked, use it, i'm not sure about mine.
     
  5. Dark

    Dark L4: Comfortable Member

    Messages:
    159
    Positive Ratings:
    135
    I second frozen, its just that repeat flag, after un ticking that sending stop to it via a trigger will work.