1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

train not showing but a trigger is

Discussion in 'Mapping Questions & Discussion' started by maxtraxv2, Jan 24, 2009.

  1. maxtraxv2

    maxtraxv2 L3: Member

    Messages:
    103
    Positive Ratings:
    3
    Last edited: Jan 24, 2009
  2. Shadow Monkey

    Shadow Monkey Super Monkey

    Messages:
    244
    Positive Ratings:
    23
  3. maxtraxv2

    maxtraxv2 L3: Member

    Messages:
    103
    Positive Ratings:
    3
    not really i had a look it looks the same as what im doing tho i should add a tfteam filter
    but that should do any think to make it go like this

    EDIT: after adding in team_train_watcher

    the pic is the same but it doesnt crash it acts like the the bomb train and runs along the track and caps but, ehat lest it working all but the trigger and model


    EDIT2: i got the train to show up i had put a train in globlename removed that and it showed up

    but i still have trigger box show up as well
    [​IMG]

    http://img153.imageshack.us/img153/7176/tftrain3to5.jpg
     
    Last edited: Jan 24, 2009
  4. Zeewier

    Zeewier L9: Fashionable Member

    Messages:
    619
    Positive Ratings:
    130
    is the trigger texture is the tracktrain?

    You should used an invisible texture (i use nodraw for payload tracktrains :) )
     
    • Thanks Thanks x 1
  5. Ezekel

    Ezekel L11: Posh Member

    Messages:
    818
    Positive Ratings:
    244
    i think valve use the clip texture for their track-train brush.
    as to the bomb model not moving... i have no idea why, but i've also seen this happen on my payload occasionally - however it appears to be client side, since it will only happen for one person. everyone else will see the bombcart model move as normal. - in these cases the bombcart model will stay put but will teleport to the track train position when a point is capped, and then move with it normally.
    i use a prop_dynamic like you, but valve actually use a prop_phys for their cart model (mainly so it will fall down the hole at the end). shouldn't make a difference, but i've come to see hammer as tempermental at times. maybe try copying valve and see what happens.
     
    • Thanks Thanks x 1
  6. Zeewier

    Zeewier L9: Fashionable Member

    Messages:
    619
    Positive Ratings:
    130
    I missed that part of the model not moving, but it should be a prop_physics_override instead of prop_dynamic
     
  7. maxtraxv2

    maxtraxv2 L3: Member

    Messages:
    103
    Positive Ratings:
    3
    it moving now

    i thort it was the brush

    thanks guys