This is getting frustrating! Blue snow? The heck?!

Discussion in 'Mapping Questions & Discussion' started by temion, Aug 17, 2009.

  1. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    This is starting to piss me off. This morning I started a new map and I'm currently working with 1 large displacement (destroyed cube set to the power of 4) to create a large large floating island. The displacement is done and works great. I notice however that *only* when trying to use the new textures from Viaduct I get some bizarre errors.

    This happens specifically with "/nature/blendrockgroundwallsnow" and is sadly the only good blend texture I can find for this project.

    Does anyone have idea what is causing this error and maybe how to fix it? Nothing comes up when I hit alt+p

    [​IMG]
     
  2. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    "Blue Snow"?
    Obviously you put your mountain under a major airline route...

    But seriously, I don't know, although I do know some folks have had crashing problems with power-of-four displacements. If you change it to a lower power (maybe slice it into separate displacements each of a of lower power) does the problem still occur?
     
    • Thanks Thanks x 2
  3. mtv22

    mtv22 L3: Member

    Messages:
    116
    Positive Ratings:
    22
    Well look on the bright side, that's a nice mountain, something I could never accomplish.
     
  4. benbrooks

    benbrooks L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Power of 4 displacements don't tend to play nice with the orange box engine. Try power of 3 ones and if it's not detailed enough, split the displacement into 2, and have both power of 3.
     
  5. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,468
    You need cubemaps.
     
  6. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    Building cube maps didn't help. :(

    Can i lower the power without destroying the displacement? Or .. if possible.. unsew the 6 faces?
     
  7. benbrooks

    benbrooks L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    In the displacement tab there is a box to change your power level, Although, I think this will unsew things slightly.
     
  8. alecom

    alecom L8: Fancy Shmancy Member

    Messages:
    516
    Positive Ratings:
    120
    Yes but after changing powers you can sew them back up easily enough
     
  9. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    Well I lowered the power to 3 and I still get blue snow. This is feeling hopeless! :(

    [​IMG]
     
  10. alecom

    alecom L8: Fancy Shmancy Member

    Messages:
    516
    Positive Ratings:
    120
    did you link the cubemap directly to the displacement face? I have no idea if that will help
     
  11. re1wind

    aa re1wind

    Messages:
    644
    Positive Ratings:
    382
    Doesn't really look like a cubemap issue. missing cubemap textures are the purple/black checkers, which this isn't. Part of the snow is normal, part of it turns light purple. If it were a cubemap issue, then all the snow would have a purple/black checker pattern.

    Looks like a shader issue limited to the snow texture. Opening up the material's vmt, and with appropriate shader-parameter-knowledge someone could help you to figure out what's going on.

    I'm also tempted to say that it's a lightmap issue if it were not for the snow texture only being affected.

    Check viaduct's light & environment settings (via the decompiled maps, which are here somewhere...) copy them into your map, compile, and see if that helps at all.
     
    Last edited: Aug 17, 2009
  12. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    I'm lost, i'm not sure exactly what I'm looking for in viaduct's entities. Perhaps someone can just take a peak at this in hammer and see.. maybe it is something obvious I am overlooking. :(
     
  13. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Does the blue color happen correspond to whatever you have set for your fog controller?
     
    Last edited: Aug 17, 2009
  14. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    It is close, however removing the fog controller entirely doesn't fix anything. :bored:

    edit: and after testing the fog controller at random colors, i still get the same blue snow.
     
    Last edited: Aug 18, 2009
  15. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Maybe it's reacting to shadow_control? Dunno.

    Long shot: Are you compiling with super-duper lighting quality? Cordon it off with the relevant lighting/fog entities and then pass -textureshadows -StaticPropPolys -StaticPropLighting to VRAD.
     
    Last edited: Aug 18, 2009
  16. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    Is that the color of your ambient lighting? Is that part of the mountian in shadows?
     
  17. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    It is. However, the shadows aren't following the form of the displacement but appear to be following the form of the original cube. I mean, if this can be solved by simply separating the faces from each other while still maintaining the shape of the displacements, then I'm all for it. However, I don't know how to break apart my displacement this way since this entire mountain is 1 brush. :confused:
     
  18. alecom

    alecom L8: Fancy Shmancy Member

    Messages:
    516
    Positive Ratings:
    120
    Use the clipping tool, you draw the line where you want to cut and use shift+x to change which part you want to discard (a/b/neither)
     
  19. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    Yeah, I'd probably cut it into 4 even pieces. Might help it light better.
     
  20. Vigilante212

    Vigilante212 L7: Fancy Member

    Messages:
    481
    Positive Ratings:
    33
    Maybe your displacement is too large. try cutting into 4 chunks see if that helps.