"The system cannot find the file specified." - Compile error

Discussion in 'Mapping Questions & Discussion' started by Rolf, Dec 23, 2008.

  1. Rolf

    Rolf L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    Sup guys.

    So I'm trying to compile this map right, it's no where near beta stage, it still needs capture points and a red spawn room, but i've got it far enough to be at least playable (with lighting, blu spawns, and setup gates)

    Anyway, so I went to run the map with everything set to normal and I got this error at the end.

    Compile log:

    Code:
    ** Executing...
    ** Command: "c:program filessteamsteamapps******sourcesdkbinorangeboxbinvbsp.exe"
    ** Parameters: -game "c:program filessteamsteamapps******team fortress 2tf" "C:HammerAutosaverawrs"
    
    Valve Software - vbsp.exe (Mar 11 2008)
    2 threads
    materialPath: c:program filessteamsteamapps******team fortress 2tfmaterials
    Loading C:HammerAutosaverawrs.vmf
    material "plaster/offwllb" not found.
    Material not found!: PLASTER/OFFWLLB
    material "brick/offwllb" not found.
    Material not found!: BRICK/OFFWLLB
    material "de_cbble/trim05" not found.
    Material not found!: DE_CBBLE/TRIM05
    material "plaster/offwllc" not found.
    Material not found!: PLASTER/OFFWLLC
    material "ground/snow01" not found.
    Material not found!: GROUND/SNOW01
    material "concrete/base01" not found.
    Material not found!: CONCRETE/BASE01
    material "carpet/offflra" not found.
    Material not found!: CARPET/OFFFLRA
    material "brick/offwlla" not found.
    Material not found!: BRICK/OFFWLLA
    material "concrete/offflrasnow" not found.
    Material not found!: CONCRETE/OFFFLRASNOW
    material "metal/drtrima" not found.
    Material not found!: METAL/DRTRIMA
    material "brick/offwllc" not found.
    Material not found!: BRICK/OFFWLLC
    material "brick/offwllbedge" not found.
    Material not found!: BRICK/OFFWLLBEDGE
    material "metal/ibeama" not found.
    Material not found!: METAL/IBEAMA
    material "concrete/offflra" not found.
    Material not found!: CONCRETE/OFFFLRA
    material "concrete/offflrb" not found.
    Material not found!: CONCRETE/OFFFLRB
    material "concrete/concretewall021a" not found.
    Material not found!: CONCRETE/CONCRETEWALL021A
    material "metal/stairsatp" not found.
    Material not found!: METAL/STAIRSATP
    material "concrete/concwsnow01" not found.
    Material not found!: CONCRETE/CONCWSNOW01
    material "brick/offwlld" not found.
    Material not found!: BRICK/OFFWLLD
    material "concrete/offceilingb" not found.
    Material not found!: CONCRETE/OFFCEILINGB
    material "concrete/offceilinga" not found.
    Material not found!: CONCRETE/OFFCEILINGA
    material "concrete/curbreda" not found.
    Material not found!: CONCRETE/CURBREDA
    material "metal/stairsafrnt" not found.
    Material not found!: METAL/STAIRSAFRNT
    material "metal/drtrimb" not found.
    Material not found!: METAL/DRTRIMB
    material "plaster/offwllg" not found.
    Material not found!: PLASTER/OFFWLLG
    material "metal/drtrimc" not found.
    Material not found!: METAL/DRTRIMC
    material "metal/offelevdrsa" not found.
    Material not found!: METAL/OFFELEVDRSA
    material "wood/offdra" not found.
    Material not found!: WOOD/OFFDRA
    material "carpet/offflrb" not found.
    Material not found!: CARPET/OFFFLRB
    material "concrete/offwlla" not found.
    Material not found!: CONCRETE/OFFWLLA
    material "plaster/offwndwa" not found.
    Material not found!: PLASTER/OFFWNDWA
    material "plaster/offwlle" not found.
    Material not found!: PLASTER/OFFWLLE
    material "plaster/offwlld" not found.
    Material not found!: PLASTER/OFFWLLD
    material "wood/offparticleboard" not found.
    Material not found!: WOOD/OFFPARTICLEBOARD
    material "wood/offdesktopsd" not found.
    Material not found!: WOOD/OFFDESKTOPSD
    material "wood/offdesktop" not found.
    Material not found!: WOOD/OFFDESKTOP
    material "ground/blendsnow_conc" not found.
    Material not found!: GROUND/BLENDSNOW_CONC
    material "ground/blendsnow_tracks" not found.
    Material not found!: GROUND/BLENDSNOW_TRACKS
    Brush 2519, Side 2: duplicate plane
    Brush 2519: bounds out of range
    Brush 2520, Side 2: duplicate plane
    Brush 2520: bounds out of range
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
    **** leaked ****
    Entity prop_detail (-1051.00 -654.00 -461.00) leaked!
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2560.0 -3072.0 -160.0)
    Leaf 0 contents: CONTENTS_SOLID 
    Leaf 1 contents: 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2048.0 -2560.0 -408.0)
    Leaf 0 contents: CONTENTS_SOLID 
    Leaf 1 contents: 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2048.0 -2560.0 -320.0)
    Leaf 0 contents: CONTENTS_SOLID 
    Leaf 1 contents: 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2048.0 -2560.0 -224.0)
    Leaf 0 contents: CONTENTS_SOLID 
    Leaf 1 contents: 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2048.0 -2560.0 -96.0)
    Leaf 0 contents: CONTENTS_SOLID 
    Leaf 1 contents: 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2048.0 -2560.0 32.0)
    Leaf 0 contents: CONTENTS_SOLID 
    Leaf 1 contents: 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2048.0 -2560.0 136.0)
    Leaf 0 contents: CONTENTS_SOLID 
    Leaf 1 contents: 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3072.0 -2560.0 -160.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    *** Suppressing further FindPortalSide errors.... ***
    Processing areas...done (0)
    Building Faces...done (0)
    Chop Details...done (0)
    Find Visible Detail Sides...
    Merged 2 detail faces...done (0)
    Merging details...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    HashVec: point outside valid range
    
    ** Executing...
    ** Command: "c:program filessteamsteamapps******sourcesdkbinorangeboxbinvvis.exe"
    ** Parameters: -game "c:program filessteamsteamapps******team fortress 2tf" "C:HammerAutosaverawrs"
    
    Valve Software - vvis.exe (Mar 11 2008)
    2 threads
    reading c:hammerautosaverawrs.bsp
    Error opening c:hammerautosaverawrs.bsp
    
    ** Executing...
    ** Command: "c:program filessteamsteamapps******sourcesdkbinorangeboxbinvrad.exe"
    ** Parameters:  -game "c:program filessteamsteamapps******team fortress 2tf" "C:HammerAutosaverawrs"
    
    Valve Software - vrad.exe SSE (Mar 11 2008)
    
          Valve Radiosity Simulator     
    2 threads
    [Reading texlights from 'lights.rad']
    [34 texlights parsed from 'lights.rad']
    
    Loading c:hammerautosaverawrs.bsp
    Error opening c:hammerautosaverawrs.bsp
    
    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:HammerAutosaverawrs.bsp" "c:program filessteamsteamapps******team fortress 2tfmapsrawrs.bsp"
    
    The command failed. Windows reported the error:
      "The system cannot find the file specified."
    Extreme failure.

    I must note that this was originally a decompiled version of (cs1.6?) cs_office which I am trying to convert for use with tf2. (cp_office) All credits of course go to valve for making the original.

    I'm not finished with replacing all of the missing textures either, which I assume could be part of the problem?

    Anyway, I am too nub at mapping to identify and rectify the problem. Can anyone help?

    edit, lol, duh forgot the skybox, but I doubt leaks would change much in the way of not being able to find the actual file.
     
    Last edited: Dec 23, 2008
  2. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    145
    material "plaster/offwllb" not found.
    Material not found!: PLASTER/OFFWLLB
    material "brick/offwllb" not found.
    Material not found!: BRICK/OFFWLLB
    material "de_cbble/trim05" not found.
    Material not found!: DE_CBBLE/TRIM05
    material "plaster/offwllc" not found.
    [........]
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2560.0 -3072.0 -160.0)
    Leaf 0 contents: CONTENTS_SOLID
    Leaf 1 contents:
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:
    [..........]


    Probably because of those errors, use the compile log checker: http://forums.tf2maps.net/showthread.php?t=910
     
  3. ProfFiendish

    ProfFiendish L2: Junior Member

    Messages:
    95
    Positive Ratings:
    10
    Looks like it has directions to look for the cs textures, but it's looking for them in the TF2 textures folder. It's probably because you haven't finished replacing textures yet?

    Does it run in TF2?
     
  4. Rolf

    Rolf L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    Well it won't even compile, so no, it won't run in tf2 =P

    @Cameron.

    The compile log checker didn't really help as I have no idea what is even causing the error.

    edit: I fixed all of the invalid texture problems, gonna try it now.
    edit2: lol, still borked
    Code:
    ** Executing...
    ** Command: "c:program filessteamsteamapps******sourcesdkbinorangeboxbinvbsp.exe"
    ** Parameters: -game "c:program filessteamsteamapps******team fortress 2tf" "C:HammerAutosavecp_office_001"
    
    Valve Software - vbsp.exe (Mar 11 2008)
    2 threads
    materialPath: c:program filessteamsteamapps******team fortress 2tfmaterials
    Error opening C:HammerAutosavecs_office_001.vmf: File C:HammerAutosavecp_office_001.vmf, line 1: No such file or directory.
    
    
    ** Executing...
    ** Command: "c:program filessteamsteamapps******sourcesdkbinorangeboxbinvvis.exe"
    ** Parameters: -game "c:program filessteamsteamapps******team fortress 2tf" "C:HammerAutosavecp_office_001"
    
    Valve Software - vvis.exe (Mar 11 2008)
    2 threads
    reading c:hammerautosavecp_office_001.bsp
    Error opening c:hammerautosavecp_office_001.bsp
    
    ** Executing...
    ** Command: "c:program filessteamsteamapps******sourcesdkbinorangeboxbinvrad.exe"
    ** Parameters:  -game "c:program filessteamsteamapps******team fortress 2tf" "C:HammerAutosavecp_office_001"
    
    Valve Software - vrad.exe SSE (Mar 11 2008)
    
          Valve Radiosity Simulator     
    2 threads
    [Reading texlights from 'lights.rad']
    [34 texlights parsed from 'lights.rad']
    
    Loading c:hammerautosavecp_office_001.bsp
    Error opening c:hammerautosavecp_office_001.bsp
    
    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:HammerAutosavecp_office_001.bsp" "c:program filessteamsteamapps******team fortress 2tfmapscp_office_001.bsp"
    
    The command failed. Windows reported the error:
      "The system cannot find the file specified."
     
    Last edited: Dec 23, 2008
  5. Earl

    Earl L6: Sharp Member

    Messages:
    284
    Positive Ratings:
    37
    Leaks and incorrect directory setup?
     
  6. Rolf

    Rolf L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    The leaks aren't a problem at the moment, I know they are there.

    As for the incorrect directory, I recently formatted my C drive and backed up my whole steamapps folder on my D drive (It's now back in the normal directory it was in before the format, though.), so that could very well be the problem. Although, I'm not sure how to change the directory settings.
     
    Last edited: Dec 23, 2008
  7. Lord Ned

    Lord Ned L7: Fancy Member

    Messages:
    421
    Positive Ratings:
    174
    Well, because Rolf is too busy being yelled at in chat right now to bother listening to me.
    30 seconds of searching.... www.interlopers.net/errors
     
  8. Rolf

    Rolf L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    Alt P returns nothing.

    i.e "No errors were found."
     
    Last edited: Dec 24, 2008
  9. Lord Ned

    Lord Ned L7: Fancy Member

    Messages:
    421
    Positive Ratings:
    174
    Do I need to C&P it some more?

    Or, it's cause you DECOMPILED it.