"The system cannot find the file specified." Any help on fixing this?

Discussion in 'Mapping Questions & Discussion' started by Luigichu, Oct 13, 2017.

  1. Luigichu

    Luigichu L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Here is my compile log.


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\download\maps\surf_tfbathroom.vmf"

    Valve Software - vbsp.exe (Jun 14 2017)
    2 threads
    materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\download\maps\surf_tfbathroom.vmf
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    Brush 101894: MAX_MAP_PLANES
    Side 5
    Texture: PROPS/METALSTAINLESS01


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\download\maps\surf_tfbathroom"

    Valve Software - vvis.exe (Jun 14 2017)
    2 threads
    reading c:\program files (x86)\steam\steamapps\common\team fortress 2\tf\download\maps\surf_tfbathroom.bsp
    Error opening c:\program files (x86)\steam\steamapps\common\team fortress 2\tf\download\maps\surf_tfbathroom.bsp

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\download\maps\surf_tfbathroom"

    Valve Software - vrad.exe SSE (Jun 14 2017)

    Valve Radiosity Simulator
    2 threads
    [Reading texlights from 'lights.rad']
    unknown light specifier type - lights

    [56 texlights parsed from 'lights.rad']

    Loading c:\program files (x86)\steam\steamapps\common\team fortress 2\tf\download\maps\surf_tfbathroom.bsp
    Error opening c:\program files (x86)\steam\steamapps\common\team fortress 2\tf\download\maps\surf_tfbathroom.bsp

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\download\maps\surf_tfbathroom.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\surf_tfbathroom.bsp"

    The command failed. Windows reported the error:
    "The system cannot find the file specified."

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\hl2.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -w 854 -h 480 -novid -sw +map "surf_tfbathroom" -steam
     
  2. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,880
    Positive Ratings:
    4,972
    You have too many brushes and it's causing your map to fail compile. Try reducing the number of brushes you have significantly.
     
    • Like Like x 1
  3. [Rx.] Christian Troy

    [Rx.] Christian Troy L4: Comfortable Member

    Messages:
    199
    Positive Ratings:
    55
    By the looks of it, seems they have some rounded brushes too and a lot of them can cause that error. Those can be changed to func_detail to avoid the error.
     
  4. Luigichu

    Luigichu L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    How would I reduce the number of brushes? So far, I haven't added too much to my map, which is just a retextured version of surf bathroom.
     
  5. [Rx.] Christian Troy

    [Rx.] Christian Troy L4: Comfortable Member

    Messages:
    199
    Positive Ratings:
    55
    [QUOTE="Luigichu, post: 430611, member: 28259" which is just a retextured version of surf bathroom.[/QUOTE]

    Certain textures on round brushes can cause the max_map_planes error too if they are world brushes or func_brushes. Changing them to func_detail should solve the problem.

    Is this a decompiled map? If so then that can be a problem too as decompiling can break stuff (not always though).