The swamp pack particles

Discussion in 'Mapping Questions & Discussion' started by MildlyMad, Aug 5, 2009.

  1. MildlyMad

    MildlyMad L2: Junior Member

    Messages:
    55
    Positive Ratings:
    5
    For me, some of the particle effects don't show up in game, namely the smoke - the water bubbles and the bouylights.
    I've changed the file in /tf/maps and tf/scripts (for the soundscapes that work) as per the instructions here: http://swamp.tf2maps.net/instructions.php
    Whats going wrong? :confused:
    Otherwise, great pack - excellent textures and models. :thumbup1:

     
  2. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    It's spelled buoy ;)

    For the bubbles... I'm not sure? More info?
     
  3. MildlyMad

    MildlyMad L2: Junior Member

    Messages:
    55
    Positive Ratings:
    5
    I'll compile again and post what loads in console.

    Code:
    Attemped to precache unknown particle system "cloud_mosq"!
    Attemped to precache unknown particle system "cloud_mosq_high"!
    Attemped to precache unknown particle system "cloud_base_high"!
    Attemped to precache unknown particle system "env_buoy_flash"!
    Attemped to precache unknown particle system "env_buoy_glow"!
    Attemped to precache unknown particle system "env_buoy_light"!
    Attemped to precache unknown particle system "cloud_moving"!
    Attemped to precache unknown particle system "slime_splash_01"!
    Attemped to precache unknown particle system "slime_splash_03"!
    Attemped to precache unknown particle system "goo_bubble"!
    Attemped to precache unknown particle system "lightning_striker"!
    Attemped to precache unknown particle system "electrical_arc_01_system"!
    Attemped to precache unknown particle system "env_rain_001_collision"!
    Attemped to precache unknown particle system "001_streaks"!
    Attemped to precache unknown particle system "env_rain_128"!
    Attemped to precache unknown particle system "env_rain_64"!
    Attemped to precache unknown particle system "env_rain_002_collision"!
    Attemped to precache unknown particle system "002_mist"!
    Attemped to precache unknown particle system "002_streaks"!
    Attemped to precache unknown particle system "swamp_constant_smoke"!
    Attemped to precache unknown particle system "waterdrip"!
    Attemped to precache unknown particle system "watersplash"!
    Attemped to precache unknown particle system "env_bouy_flash"!
    
    I just copied + pasted that particle systems from the map "swamp_zoo" :unsure:

    Merged two posts -zpq
     
    Last edited by a moderator: Aug 5, 2009
  4. Trotim

    aa Trotim

    Messages:
    1,180
    Positive Ratings:
    995
    env_buoy_flash is misspelled in the swamp_zoo.vmf as env_bouy_flash. It should work when you fix that typo.

    The bubbles work fine here - keep in mind in the map it's a one-time effect that is shown when you first spawn.

    EDIT: Alright, now you seem to have a problem when inserting the particles in another map? Are you sure you renamed the *_particles.txt properly? When your map is called "cp_trotim" it has to be "cp_trotim_particles.txt".
     
    • Thanks Thanks x 1
  5. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    Mildly: did you follow the instructions about the mapname_particles.txt?
     
  6. zpqrei

    aa zpqrei Theme Changer Extraordinaire

    Messages:
    1,067
    Positive Ratings:
    1,122
    Foda's mistake :p

    I'll edit it for the expansion we're working on.
     
    • Thanks Thanks x 1
  7. MildlyMad

    MildlyMad L2: Junior Member

    Messages:
    55
    Positive Ratings:
    5
    Oh, thats disapointing - I was hoping that they would continue forever, so that I can have a toxic waste swamp.

    ABS - yes, other particles like the bugs and water drips work fine.
     
  8. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    You would just need to have a timer periodically fire the "start" input to the particle system.
     
    • Thanks Thanks x 1
  9. MildlyMad

    MildlyMad L2: Junior Member

    Messages:
    55
    Positive Ratings:
    5
    Ah, okay then. I'll try that. Thanks for the help and info :D